Previous Thread
Next Thread
Print Thread
Rate Thread
Page 2 of 2 1 2
Joined: Feb 2004
Posts: 182
Member
Offline
Member
Joined: Feb 2004
Posts: 182
Runs with me in the forum.

Sponsored Links
Joined: Jul 2001
Posts: 808
Coder
Offline
Coder
Joined: Jul 2001
Posts: 808
one problem gone on my checklist, thanks for testing.

Joined: Jul 2001
Posts: 808
Coder
Offline
Coder
Joined: Jul 2001
Posts: 808
I take a closer look to TLD running under UBB.threads 7.3
I found some layout problems if you use sidebars. I try to fix it and here you can download my fix. I split the template in links and links_admin.

Attached Images
links.zip (17.04 KB, 4 downloads)
SHA1: f174397297d048343fa2b18f1a1fb49319c6138c
Joined: Mar 2000
Posts: 21,079
Likes: 3
I type Like navaho
Offline
I type Like navaho
Joined: Mar 2000
Posts: 21,079
Likes: 3
Thank you Zarzal smile

I am making some headway in updating this to use more of 7.3's features (like SEO cats and links) and completely 'wordletizing' it. It will be a few days before I have it completed for testing tho... headed to Austin shortly and I need to get some work done here smile

You can see some of the progress here:

http://www.praisecafe.org/forum/ubbthreads.php/ubb/links

At that point we need to see about putting some of the features we had added for 2.2-2.5 back that were skipped in the update to 7.x crazy


- Allen wavey
- What Drives You?
Joined: Jul 2001
Posts: 808
Coder
Offline
Coder
Joined: Jul 2001
Posts: 808
This looks nice. I still wait for the final release.

Sponsored Links
Joined: Mar 2000
Posts: 21,079
Likes: 3
I type Like navaho
Offline
I type Like navaho
Joined: Mar 2000
Posts: 21,079
Likes: 3
hmmm...


I take it no-one has actually run this script? If so, are you able to actually add links?

When I submit the script to add the link it refreshes the page back to the submit link page - this time with all fields blank *except* now the title you added for the previously submitted site is now sitting in the category box.

smash

Not counting the install bug (it won't install without creating the tables manually), this is still pretty buggy. Will need some more work before it's ready for public use.


- Allen wavey
- What Drives You?
Joined: Jul 2001
Posts: 808
Coder
Offline
Coder
Joined: Jul 2001
Posts: 808
add a link an my page or on your page? On my website it works fine.
/update: on your page i get a blank screen if I try and the url looks misformed:
http://www.praisecafe.org/forum/ubbthreads.php/ubb/links/op/Submit_Link/cat_id/.html
I dont use the 'add .html' option on my board.

Last edited by Zarzal; 06/13/2008 1:44 PM.
Joined: Mar 2000
Posts: 21,079
Likes: 3
I type Like navaho
Offline
I type Like navaho
Joined: Mar 2000
Posts: 21,079
Likes: 3
Zarzal, do you mind attaching the links.inc.php file you are using? I am having a few issues with the submission. And if you can, can you see about turning on the .html option just for a minute to test adding one site to see if that's the issue? Turning the .html extension off didn't fix the issue on my site.


- Allen wavey
- What Drives You?
Joined: Jul 2001
Posts: 808
Coder
Offline
Coder
Joined: Jul 2001
Posts: 808
I will watch my board and if I see a timeslot with less user I will test it.

Joined: Mar 2000
Posts: 21,079
Likes: 3
I type Like navaho
Offline
I type Like navaho
Joined: Mar 2000
Posts: 21,079
Likes: 3
Danke, and when you get a chance, please attach the links.inc file, if you give it a .txt extension you should be able to attach it fine. smile


- Allen wavey
- What Drives You?
Sponsored Links
Joined: Jul 2001
Posts: 808
Coder
Offline
Coder
Joined: Jul 2001
Posts: 808
here we go:

Attached Images
links.inc.php.txt (46.95 KB, 5 downloads)
SHA1: 3811484ccd5924556f603e96236fedb1b3b14e99
Joined: Mar 2000
Posts: 21,079
Likes: 3
I type Like navaho
Offline
I type Like navaho
Joined: Mar 2000
Posts: 21,079
Likes: 3
Thank you - I get the same problem like I mentioned before. I am using mysql and php 5+. I have no idea what the problem might be. If you look at the form for submitting the info there's something odd going on with the categories, there's several options in there for categories. I'm going to work on it and see if I can get it cleaned up.


- Allen wavey
- What Drives You?
Joined: Mar 2000
Posts: 21,079
Likes: 3
I type Like navaho
Offline
I type Like navaho
Joined: Mar 2000
Posts: 21,079
Likes: 3
Looking at this line:



When I view source from the web page it's getting an empty value:



This line:



I get an empty value for $cat_id and $title:



Not sure what's going on...


- Allen wavey
- What Drives You?
Joined: Jul 2001
Posts: 808
Coder
Offline
Coder
Joined: Jul 2001
Posts: 808
Do you ran any kind of security plugins on your websever? ModSecurity?

Joined: Mar 2000
Posts: 21,079
Likes: 3
I type Like navaho
Offline
I type Like navaho
Joined: Mar 2000
Posts: 21,079
Likes: 3
No, but I am running php 5.1.x - I wonder if this isn't up to php 5.1's coding standards...


- Allen wavey
- What Drives You?
Joined: Mar 2000
Posts: 21,079
Likes: 3
I type Like navaho
Offline
I type Like navaho
Joined: Mar 2000
Posts: 21,079
Likes: 3
Part of the issue is "title" is used for the name of the site being submitted and the name of the category being submitted to. Need to update them to cat_title and url_title.


- Allen wavey
- What Drives You?
Joined: Mar 2000
Posts: 21,079
Likes: 3
I type Like navaho
Offline
I type Like navaho
Joined: Mar 2000
Posts: 21,079
Likes: 3
OK, found the issue. Working on wordlets right now.


- Allen wavey
- What Drives You?
Joined: Jul 2001
Posts: 808
Coder
Offline
Coder
Joined: Jul 2001
Posts: 808
I test the .html extension on my site nd it work. Spider frindly urls too.

Joined: Oct 2006
Posts: 7
Lurker
Offline
Lurker
Joined: Oct 2006
Posts: 7
Hmmm i just installed this, manually put in the tables as noted on the past posts, and it worked. Awesome... I dont notice any issues yet. Running version 7.1 threads still though. frown but at least this is working now for our site.

I loved this mod years ago, and so glad to have it back again! Thanks for all your work on this guys!

Joined: Mar 2000
Posts: 21,079
Likes: 3
I type Like navaho
Offline
I type Like navaho
Joined: Mar 2000
Posts: 21,079
Likes: 3
Glad you like it, it should work pretty well for all 7.x series, I believe.


- Allen wavey
- What Drives You?
Joined: Jul 2001
Posts: 808
Coder
Offline
Coder
Joined: Jul 2001
Posts: 808
I just encounter a little problem on my site. My mods seems not to be able to click the green LED to edit a link in the DB. They get a message that they must be admin to do this. I cannot find the check. I guess I must just change a little thing to allow mods to edit the links.

Can anyone assist me in this case?

Joined: Mar 2000
Posts: 21,079
Likes: 3
I type Like navaho
Offline
I type Like navaho
Joined: Mar 2000
Posts: 21,079
Likes: 3
Do you have a link to it Zarzal?


- Allen wavey
- What Drives You?
Joined: Jul 2001
Posts: 808
Coder
Offline
Coder
Joined: Jul 2001
Posts: 808
Link to what? The Link DB? http://www.dragonclan-forum.de/board/ubbthreads.php?ubb=links

But the link dont help you because you are not a mod smile If you register I can change it if you like.

I guess its a missing compare of the rights. it must be administratos && moderatrors or something like this.

In links.inc starting line 109 I found this:
Code
// Set links admin link
if (($user['USER_MEMBERSHIP_LEVEL'] != 'Administrator') && ($user['USER_MEMBERSHIP_LEVEL'] != 'Moderator')) {
$links_admin_delete_link = ""; // Don't give option to delete a link
}
else {
$links_admin_link = "   *  <a href=\"{$config['BASE_URL']}/ubbthreads.php?ubb=links_admin&op=links_admin\">{$ubbt_lang['LINKS_ADMIN']}</a>"; // Provide a link to the links admin
$links_admin_delete_link = "  *  <a href=\"{$config['BASE_URL']}/ubbthreads.php?ubb=links_admin&op=delete_link&lid={$row[lid]}\">{$ubbt_lang['LINKS_ADMIN_DELETE']}</a>   ";
}
I wonder why this dont work

Last edited by Zarzal; 02/25/2009 6:12 AM.
Joined: Jul 2001
Posts: 808
Coder
Offline
Coder
Joined: Jul 2001
Posts: 808
ahhh, found it. wrong settings in links_admin.inc.php smile I change the permissions in top of the file and all work as it should.

Joined: Mar 2007
Posts: 94
Power User
Offline
Power User
Joined: Mar 2007
Posts: 94
is there a updated download of this with all the compiled fixes etc?

has anyone used if on UBB 7.5.3 ?

does anyone have a link to where I can see this in action?

Joined: Jan 2000
Posts: 244
Likes: 4
Beta Tester
Offline
Beta Tester
Joined: Jan 2000
Posts: 244
Likes: 4
I believe Fishtails has it on his site still. It is kinda hidden if not registered.
But you can see it at
http://www.firstcoastangler.com/forum/ubbthreads.php?ubb=links
Matter of fact try this topic HERE
It is a more current topic and it has a demo link that is more active.
I just noticed fishtails is using this version(ubb links) in lieu of the tld flavor

Last edited by Ruben Rocha; 10/04/2009 5:56 PM. Reason: added comment
Joined: Mar 2000
Posts: 21,079
Likes: 3
I type Like navaho
Offline
I type Like navaho
Joined: Mar 2000
Posts: 21,079
Likes: 3
The first post in the topic Ruben linked to should contain current code and there's no reason it shouldn't work on current versions.

"fishtails" most likely has an oooooooollllldlddd version (pre-this version).


- Allen wavey
- What Drives You?
Joined: Mar 2007
Posts: 94
Power User
Offline
Power User
Joined: Mar 2007
Posts: 94
thanx allen, will check it out this evening

have all the SQL issues been sorted out? or do I still need to manually create the various tables, etc?

Joined: Mar 2000
Posts: 21,079
Likes: 3
I type Like navaho
Offline
I type Like navaho
Joined: Mar 2000
Posts: 21,079
Likes: 3
It's an automagic install, there should be instructions in the first post.


- Allen wavey
- What Drives You?
Joined: Mar 2000
Posts: 21,079
Likes: 3
I type Like navaho
Offline
I type Like navaho
Joined: Mar 2000
Posts: 21,079
Likes: 3
Oh, and the demo forum it links to is running current ubb.threads code. smile


- Allen wavey
- What Drives You?
Joined: Jan 2000
Posts: 244
Likes: 4
Beta Tester
Offline
Beta Tester
Joined: Jan 2000
Posts: 244
Likes: 4
Okay Allen I am confused now.
What Mod is really the most current. ubb links or this tld version
I can't find a demo link on this post. At least not the topic start post.

Joined: Mar 2000
Posts: 21,079
Likes: 3
I type Like navaho
Offline
I type Like navaho
Joined: Mar 2000
Posts: 21,079
Likes: 3
The other one is much more current, Josh based this version off the fishtails version and missed out on quite a bit of the updates - plus this one states it's for threads 7.2, the other is for 7.3+


- Allen wavey
- What Drives You?
Joined: Jan 2000
Posts: 244
Likes: 4
Beta Tester
Offline
Beta Tester
Joined: Jan 2000
Posts: 244
Likes: 4
Okay thanks. I thought I was confused but I guess not now.

Page 2 of 2 1 2

Link Copied to Clipboard
Donate Today!
Donate via PayPal

Donate to UBBDev today to help aid in Operational, Server and Script Maintenance, and Development costs.

Please also see our parent organization VNC Web Services if you're in the need of a new UBB.threads Install or Upgrade, Site/Server Migrations, or Security and Coding Services.
Recommended Hosts
We have personally worked with and recommend the following Web Hosts:
Stable Host
bluehost
InterServer
Visit us on Facebook
Member Spotlight
Gardener
Gardener
Sweden, Stockholm
Posts: 1,715
Joined: May 1999
Forum Statistics
Forums63
Topics37,546
Posts293,802
Members13,838
Most Online5,166
Sep 15th, 2019
Today's Statistics
Currently Online 241
Topics Created 0
Posts Made 0
Users Online 1
Birthdays 27
Top Posters
AllenAyres 21,079
JoshPet 10,369
LK 7,394
Lord Dexter 6,708
Gizmo 5,806
Greg Hard 4,625
Top Posters(30 Days)
isaac 8
Top Likes Received
isaac 46
Gizmo 10
Brett 7
Morgan 2
Top Likes Received (30 Days)
isaac 5
The UBB.Developers Network (UBB.Dev/Threads.Dev) is ©2000-2020 VNC Web Services

 
Powered by UBB.threads™ PHP Forum Software 7.7.5
(Snapshot build 20200925.dev)
Responsive Width:

PHP: 5.4.45 Page Time: 0.082s Queries: 84 (0.026s) Memory: 3.6018 MB (Peak: 3.9791 MB) Data Comp: Zlib Server Time: 2020-09-28 11:15:53 UTC
Valid HTML 5 and Valid CSS