Previous Thread
Next Thread
Print Thread
Rate Thread
Joined: Nov 2006
Posts: 24
st515O Offline OP
Newbie
OP Offline
Newbie
Joined: Nov 2006
Posts: 24
Anyone know what this error means in ubb classic? It shows up when trying to view the main page. It goes away for a few hours when the cache is cleared, but always comes back. Nothing is wrong or abnormal about member number 1's profile and I can't figure out.

It looks like this http://72.14.253.104/search?q=cache:sVdttRgUF6EJ:www.pdngallery.com/cgi-bin/ubb/ultimatebb.cgi%3Fubb%3Dget_profile%3Bu+%22No+member+profile+found+for+member+number:%22&hl=en&ct=clnk&cd=16&gl=us&client=firefox-a


Sponsored Links
Joined: Jan 2000
Posts: 5,806
Likes: 10
UBB.Dev / UBB.Wiki Owner
Time Lord
Offline
UBB.Dev / UBB.Wiki Owner
Time Lord
Joined: Jan 2000
Posts: 5,806
Likes: 10
A member profile may be currupted; you should try rebuilding the member meta deta


UBB.Dev - Putting Dev into UBB.threads
Company: VNC Web Services - UBB.threads Scripts and Scripting, Install and Upgrade Services, Site and Server Maintenance.
Forums: A Gardeners Forum, I Find Rocks, Scouters World, and UGN Security
UBB.Threads: My UBB Themes, My UBB Scripts
Joined: Nov 2006
Posts: 24
st515O Offline OP
Newbie
OP Offline
Newbie
Joined: Nov 2006
Posts: 24
Thanks. It didn't help. I did find this out though, when clearning the cache, it's the " Miscellaneous Pages
Includes the UBB Codeâ„¢ Definition page, the FAQ page, and the Daily Active Topics page." option that fixes this problem. Odd. I think it has something to do with the daily active topics but who knows. Anyone know the details of how this function works in the cache and have any tips on trouble shootin it?

Joined: Nov 2006
Posts: 24
st515O Offline OP
Newbie
OP Offline
Newbie
Joined: Nov 2006
Posts: 24
I've rebuilt everything, search index, post history, forum stats, etc with no luck. Only disabling the accelerator seems to fix this and I'm at a loss. If the accelerator is enabled, it takes 2-6 hours for the error to pop up. Any ideas anyone? I don't even know how to start debuging this error.



ps- I think this is the wrong section for this post so feel free to move it to a more proper location.

Joined: Jan 2000
Posts: 5,073
Admin Emeritus
Offline
Admin Emeritus
Joined: Jan 2000
Posts: 5,073
confused

okay, this was bad enough to make me log in for the first time in over six months.

Let's take a look at that Google cache entry.

www. pdngallery.com/cgi-bin/ubb/ultimatebb.cgi%3Fubb%3Dget_profile%3Bu+%22No+member+profile+found+for+member+number:%22

->

www. pdngallery.com/cgi-bin/ubb/ultimatebb.cgi?ubb=get_profile;u "No member profile found for member number:"

(mutter mutter unable to disable UBBCode mutter mutter)

This is not your front page. This is a public profile with no rofile number passed in... or, rather, with a *string* being passed in.

Huh?

Also, the error message is very specific -- profile 0 can't be found. Not 00000000, not 1, not 00000001, but 0. That means that either a literal zero is being passed in, or something (such as a string) that is being mangled into a zero is being passed in.

In other words, I call BS on the data. Something is very wrong there. I call shenanigans on this wtfery.

Also, hi.


UBB.classic: Love it or hate it, it was mine.
Sponsored Links
Joined: Jan 2000
Posts: 5,806
Likes: 10
UBB.Dev / UBB.Wiki Owner
Time Lord
Offline
UBB.Dev / UBB.Wiki Owner
Time Lord
Joined: Jan 2000
Posts: 5,806
Likes: 10
i told everyone I'd get him back....


UBB.Dev - Putting Dev into UBB.threads
Company: VNC Web Services - UBB.threads Scripts and Scripting, Install and Upgrade Services, Site and Server Maintenance.
Forums: A Gardeners Forum, I Find Rocks, Scouters World, and UGN Security
UBB.Threads: My UBB Themes, My UBB Scripts
Joined: Nov 2006
Posts: 24
st515O Offline OP
Newbie
OP Offline
Newbie
Joined: Nov 2006
Posts: 24
Oh wow, thank you gizmo... if I never expected you (or anyone) to summon the UBB god himself! :worship:

Charles, thank you so much for chiming in.
I understand your explanation for the google cache link, it's obvious based on the URL that the ultimatebb.cgi script is being fed an incomplete "?ubb=get_profile&u" (with no =xxxxxxx) thus resulting in the No member profile found error. I appologise for my oringal post not being clear, but while my error message the same, how I go about recieving it is different. I make no ?ubb=get_profile&u call.

My problem is, I get the "No member profile found for member number: 1" error when trying simply accessing /cgi-bin/ultimatebb.cgi (the main/summary page). No ?ubb=get_profile&u is present... it's simply the front/main page I'm trying to view. After trying several things, the only fix I found is either clearing the "Miscellaneous Pages
Includes the UBB Codeâ„¢ Definition page, the FAQ page, and the Daily Active Topics page." part of the cache, which fixes the problem for a few hours or I can fix it for good and take a performance hit by disabling the UBB.classic Accelerator. I hope this makes sense. I've been a very happy UBB.classic user for 7 years! Thanks Charles.

Joined: Nov 2006
Posts: 24
st515O Offline OP
Newbie
OP Offline
Newbie
Joined: Nov 2006
Posts: 24
Just brain storming......maybe a few days before the problem started, I zapped the .threads files and some other v5.x junk I had lying around for half a decade after I upgraded to version six five of the board. I quickly realized the forum_*.threads files were needed so I 'rebuilt' everything and was good to go. This is the only change on my end that could have possibly caused this problem. I'm also running PHP 4,3,9(safe mode) which could probably use a version upgrade.... but I've ran .classic on much older versions/boxes with no problems (remember Netscape Fasttrack server? remember irix6.4? laugh )

Last edited by st5150; 03/13/2007 4:07 AM.
Joined: Mar 2000
Posts: 21,079
Likes: 3
I type Like navaho
Offline
I type Like navaho
Joined: Mar 2000
Posts: 21,079
Likes: 3
Hey CC! wavey


- Allen wavey
- What Drives You?
Joined: Mar 2000
Posts: 21,079
Likes: 3
I type Like navaho
Offline
I type Like navaho
Joined: Mar 2000
Posts: 21,079
Likes: 3
It never hurts to keep your php and perl updated to relatively current offerings, tho as we get further and further from .classic's EOL who knows how the scripts will work in perl 6 and php 5+.


- Allen wavey
- What Drives You?
Sponsored Links
Joined: Jan 2000
Posts: 5,073
Admin Emeritus
Offline
Admin Emeritus
Joined: Jan 2000
Posts: 5,073
Quote
remember Netscape Fasttrack server? remember irix6.4?
That sound you just heard from Seattle was my head exploding. Ouch.

Quote
I quickly realized the forum_*.threads files were needed so I 'rebuilt' everything and was good to go. This is the only change on my end that could have possibly caused this problem.
Totally serious here. Go nuke them again, and do another rebuild... and then go back and make sure that they've all been rebuilt.

If it's a problem with the topic data, it should be detected during the rebuild.

If it's a problem with the member data... eh, dunno, this is still a giant set of wtf, and I haven't even looked at the code in over a year, so who knows.


UBB.classic: Love it or hate it, it was mine.
Joined: Jan 2000
Posts: 5,806
Likes: 10
UBB.Dev / UBB.Wiki Owner
Time Lord
Offline
UBB.Dev / UBB.Wiki Owner
Time Lord
Joined: Jan 2000
Posts: 5,806
Likes: 10
Lol it exploded last night when i linked you to this thread too... I thought St Hellens blew again... It was just the head of cc...



UBB.Dev - Putting Dev into UBB.threads
Company: VNC Web Services - UBB.threads Scripts and Scripting, Install and Upgrade Services, Site and Server Maintenance.
Forums: A Gardeners Forum, I Find Rocks, Scouters World, and UGN Security
UBB.Threads: My UBB Themes, My UBB Scripts
Joined: Nov 2006
Posts: 24
st515O Offline OP
Newbie
OP Offline
Newbie
Joined: Nov 2006
Posts: 24
Well I zapped the .thread files, rebuilt the post stats then rebuilt the member stats. Enabled the accelerator and 5.5 hours later, the error popped up again frown I'm running out of things to try....its starting to become more witchcraft than science. I'm wondering if a good place to start is looking at exactly what is cleared under the "Miscellaneous Pages
Includes the UBB Codeâ„¢ Definition page, the FAQ page, and the Daily Active Topics page." option? Also, the cache directory seems to be randomly generated... for example cache-CTX3K395 Is there a way to change this? If I zap it with a rm -rf , the board script instantly recreates it. I saw the cache directory is listed in vars_config.inc.php, so I'm pondering editing the script to make my own cache directory name.... but this could be the start of the end for the board.

Joined: Nov 2006
Posts: 24
st515O Offline OP
Newbie
OP Offline
Newbie
Joined: Nov 2006
Posts: 24
Renamed the cache directory in both the cgi and php vars config files..... started out with a brand new fresh copy of the cache directory.... 6 hours later back to the same error.

I also verified all the members files were ASCII and not binary with the 'file' command ( file *.cgi | grep -v ASCII ).

Trying to prune some old posts now.

Interesting enough, it seems the error started in one forum, then one by one it spread to the other forums until finally the mail ultimatebb.cgi script started giving the error.

The saga continues....


EDIT: Using the 'Upgrade Your UBB.Classic' option made the error go away for 30 minutes. Odd, I haven't looked at the code, but from the looks of things I always thought it only compared version numbers of files and not much more.

Last edited by st5150; 03/16/2007 2:30 AM.
Joined: Jan 2000
Posts: 5,806
Likes: 10
UBB.Dev / UBB.Wiki Owner
Time Lord
Offline
UBB.Dev / UBB.Wiki Owner
Time Lord
Joined: Jan 2000
Posts: 5,806
Likes: 10
Lol the "upgrade your ubb" button runs updates on your vars files; theres a reason it's part of an upgrade wink


UBB.Dev - Putting Dev into UBB.threads
Company: VNC Web Services - UBB.threads Scripts and Scripting, Install and Upgrade Services, Site and Server Maintenance.
Forums: A Gardeners Forum, I Find Rocks, Scouters World, and UGN Security
UBB.Threads: My UBB Themes, My UBB Scripts
Joined: Nov 2006
Posts: 24
st515O Offline OP
Newbie
OP Offline
Newbie
Joined: Nov 2006
Posts: 24
Gizmo, what do you mean by 'runs updates' ? I started to glance at the code, but got distracted.

Joined: Nov 2006
Posts: 24
st515O Offline OP
Newbie
OP Offline
Newbie
Joined: Nov 2006
Posts: 24
Keep your fingers crossed everyone..... I did a bunch of things including restoring missing files in the user ratings and raters directories. Almost 12 hours and going strong.

Joined: Jan 2000
Posts: 5,806
Likes: 10
UBB.Dev / UBB.Wiki Owner
Time Lord
Offline
UBB.Dev / UBB.Wiki Owner
Time Lord
Joined: Jan 2000
Posts: 5,806
Likes: 10
Well, part of running an upgrade within classic is to click the "upgrade your ubb" button, it will apply any specified updates to your variables files, since they are not touched by the upgrade .zip's uploads.


UBB.Dev - Putting Dev into UBB.threads
Company: VNC Web Services - UBB.threads Scripts and Scripting, Install and Upgrade Services, Site and Server Maintenance.
Forums: A Gardeners Forum, I Find Rocks, Scouters World, and UGN Security
UBB.Threads: My UBB Themes, My UBB Scripts
Joined: Nov 2006
Posts: 24
st515O Offline OP
Newbie
OP Offline
Newbie
Joined: Nov 2006
Posts: 24
I spoke too soon, after 4 hours the error popped up.... but I found a new way to get it to go away, I simply viewed the Configuration Settigns, didn't change a thing and clicked "Update Configuration Settings" .... gonna go look at the code now to see exactly what's changed/touched when I do that.


Joined: Nov 2006
Posts: 24
st515O Offline OP
Newbie
OP Offline
Newbie
Joined: Nov 2006
Posts: 24
Well guys, I did some digging and this is what I found.... odd corruption in the summary.html cache file and it seems to have to do with the recent visitors settings. Check it out:

The bad /cache-CTX3K395/ubb_files/summary/summary.html has this in it:

%0A%3Ctable%20border%3D%220%22%20cellpadding%3D%221%22%20cellspacing%3D%221%22%20width%3D%2295%25%22%20align%3D%22center%22%3E%0A%3Ctr%20bgcolor%3D%22%23000000%22%3E%3Ctd%3E%0A%3Ctable%20border%3D%220%22%20width%3D%22100%25%22%20cellpadding%3D%223%22%20cellspacing%3D%220%22%3E%0A", "%0A%3C%2Ftable%3E%3C%2Ftd%3E%3C%2Ftr%3E%3C%2Ftable%3E%0A", "3") ?>

If I view this HTML file in a browser, it displays this junk instead of the island on the bottom where the recent visitors should be.


A good summary.html has this line instead:





Here is what that function is defined as

Code

function pntfGetCacheForSummary ($category, $TBT, $TBB, $colspan) {
global $NonCGIPath, $cache_pw, $PNTFPrune, $TheFile;

$TBT = rawurldecode($TBT);
$TBB = rawurldecode($TBB);

$fto = $NonCGIPath . "/cache-" . $cache_pw . "/pntf/9999";
if($category != "") {
$fto .= "_$category";
} // end if
$fto .= ".cgi";
if(file_exists($fto)) {
$info = stat($fto);
if($info[9] > (time() - ($PNTFPrune * 60))) {
$fo = join("", file($fto));
echo("$TBT$fo$TBB");
// echo "Found the file, and got these: '$category', '$TBT', '$TBB', '$colspan'";
} else {
unlink($TheFile); // Delete the cache file we just read so the next visit will go to the CGI script to regen PNTF.
$fo = join("", file($fto));
echo("$TBT$fo$TBB");
} // end if
} // end if
} // end func

So now its on to figure out what's $TBT
My perl is very rusty, but my PHP never existed in the first place smile

Last edited by st5150; 03/17/2007 5:30 PM.
Joined: Oct 2000
Posts: 2,223
Veteran
Offline
Veteran
Joined: Oct 2000
Posts: 2,223
$TBT and $TBB are, as I recall, table border top and table border bottom, as defined in your style settings.


Picture perfect penmanship here.
Joined: Mar 2000
Posts: 21,079
Likes: 3
I type Like navaho
Offline
I type Like navaho
Joined: Mar 2000
Posts: 21,079
Likes: 3
si, found in the public_common.pl template.


- Allen wavey
- What Drives You?
Joined: Nov 2006
Posts: 24
st515O Offline OP
Newbie
OP Offline
Newbie
Joined: Nov 2006
Posts: 24
Thanks for all your help guys. To make a long story short, after countless trials and tribulations, I've fixed the problem. I can't tell you what the solution exactly was though--- I was so desperate, I was changing many things at once, but having the member directory in the same path as the cgi's, as well as zapping vars_config and starting fresh seems to have done it.


BUT


I now have a new error. This error is more minor, since the board still works with it.

All the URL's are appendede with a =nfx when a user is logged in. According to CC: https://www.ubbdev.com/forums/ubbthreads.php/ubb/showflat/Number/181552/page/110

"nfx == No File_eXists, meaning that the currently logged in user's profile is missing."

I assume CC means missing from the cache?

The board works fine, its just that the cache hit is reduced by almost two thirds.



Joined: Oct 2000
Posts: 2,223
Veteran
Offline
Veteran
Joined: Oct 2000
Posts: 2,223
I'm thinking you have a pm from someone that doesn't exist or a post by someone that doesn't exist.


Picture perfect penmanship here.
Joined: Nov 2006
Posts: 24
st515O Offline OP
Newbie
OP Offline
Newbie
Joined: Nov 2006
Posts: 24
navaho, this can be very insightful. I did have some corruption in the pm_users directory... had complaints of PMs in users inboxes that didn't belong to them and incorrect pm counts. The problem was fixed by deleting the improper PMs from their pm_users file. I never figured this to be related to my problem(s) though. Even accounts that have no PMs show the nfx.... and the big reduction in cache % leads me to believe everyone is having this issue.


This could be off topic, but while we're here.... can someone explain Cookie_Number? I see it in the vars config and in the pm_users files.

Joined: Jan 2000
Posts: 5,073
Admin Emeritus
Offline
Admin Emeritus
Joined: Jan 2000
Posts: 5,073
Cookie_Number is a unique postfix given to all of the cookie names. It's assigned randomly to the board during initial install, and is used to allow multiple installations on the same domain name. Without the postfix, there'd be some pretty interesting cookie conflicts.

As for the PM funkyness... there used to be a utility that can rebuild PM indexes, but I dunno if it's still available. However, the very fact that there was corruption present tells me that your board has some bad mojo...


UBB.classic: Love it or hate it, it was mine.
Joined: Nov 2006
Posts: 24
st515O Offline OP
Newbie
OP Offline
Newbie
Joined: Nov 2006
Posts: 24
Thanks for the info. Any idea what the PM index utility was called or who wrote it? Maybe I can google the file name or track down the original author.

The corruption is very old... it was due to an early RAID controller that corrupted data when the box froze. I ran a file * | grep data to find the corrupted files, but I never bothered with anything more than that. A real PM rebuild utility would be great.

I wish I was more active with other ubb users half a decade ago. It would have saved me hours of time spent reinventing the wheel.

Joined: Jan 2000
Posts: 5,806
Likes: 10
UBB.Dev / UBB.Wiki Owner
Time Lord
Offline
UBB.Dev / UBB.Wiki Owner
Time Lord
Joined: Jan 2000
Posts: 5,806
Likes: 10
I believe CC wrote it, but it'd be infopop ware and a lot of that seems to be missing now since converting to groupee (including the yaml files it'd seem).

I know we had several discussions on file corruption here at ubbdev a couple of years back, so your best bet is searching for "corrupt" or something and weeding through the results...

Why reinvent the wheel when you can get CC or Rick to do it for me wink


UBB.Dev - Putting Dev into UBB.threads
Company: VNC Web Services - UBB.threads Scripts and Scripting, Install and Upgrade Services, Site and Server Maintenance.
Forums: A Gardeners Forum, I Find Rocks, Scouters World, and UGN Security
UBB.Threads: My UBB Themes, My UBB Scripts
Joined: Oct 2000
Posts: 2,223
Veteran
Offline
Veteran
Joined: Oct 2000
Posts: 2,223
It's not missing, nor are the yaml files. In particular, the PM rebuilder was never, ever on the website.

All you need do is just what you've always been able to do. Put in a ticket and ask. Ask, and you shall receive. smile The PM rebuilder was never on the website to my knowledge. The downloads page is still there (http://www.ubbcentral.com/downloads), though very very out of date. Still in the same place as always. The rebuilder is not listed. Has never been. I seem to recall there being some issues with it therefor Charles never wanted to make it widely available. I quite honestly do not remember what the issues were. I haven't messed with some of this stuff in 2 or more years now. Make a complete backup before you run it is all I can tell you. Put in a ticket and we'll get you a copy.


Picture perfect penmanship here.

Link Copied to Clipboard
Donate Today!
Donate via PayPal

Donate to UBBDev today to help aid in Operational, Server and Script Maintenance, and Development costs.

Please also see our parent organization VNC Web Services if you're in the need of a new UBB.threads Install or Upgrade, Site/Server Migrations, or Security and Coding Services.
Recommended Hosts
We have personally worked with and recommend the following Web Hosts:
Stable Host
bluehost
InterServer
Visit us on Facebook
Member Spotlight
Posts: 70
Joined: January 2007
Forum Statistics
Forums63
Topics37,546
Posts293,802
Members13,838
Most Online5,166
Sep 15th, 2019
Today's Statistics
Currently Online 260
Topics Created 0
Posts Made 0
Users Online 1
Birthdays 28
Top Posters
AllenAyres 21,079
JoshPet 10,369
LK 7,394
Lord Dexter 6,708
Gizmo 5,806
Greg Hard 4,625
Top Posters(30 Days)
isaac 8
Top Likes Received
isaac 46
Gizmo 10
Brett 7
Morgan 2
Top Likes Received (30 Days)
isaac 5
The UBB.Developers Network (UBB.Dev/Threads.Dev) is ©2000-2020 VNC Web Services

 
Powered by UBB.threads™ PHP Forum Software 7.7.5
(Snapshot build 20200925.dev)
Responsive Width:

PHP: 5.4.45 Page Time: 0.088s Queries: 73 (0.035s) Memory: 3.5309 MB (Peak: 3.8809 MB) Data Comp: Zlib Server Time: 2020-09-28 12:55:15 UTC
Valid HTML 5 and Valid CSS