Previous Thread
Next Thread
Print Thread
Rate Thread
Page 5 of 6 1 2 3 4 5 6
Re: [6.7] [beta] UBB.Uploader
#203111 12/12/2005 3:22 PM
Joined: Jun 2002
Posts: 111
Member
Offline
Member
Joined: Jun 2002
Posts: 111
Quote
Originally posted by elzool:


Form validation errors:

: You did not enter a value for this field
: You did not enter a value for this field

This means u do not have the mega mod installed.

Or install the mega mod first or use the install.txt i just posted.

Sponsored Links
Re: [6.7] [beta] UBB.Uploader
#203112 12/12/2005 9:40 PM
Joined: Jan 2000
Posts: 5,795
Likes: 8
UBB.Dev / UBB.Wiki Owner
Time Lord
Offline
UBB.Dev / UBB.Wiki Owner
Time Lord
Joined: Jan 2000
Posts: 5,795
Likes: 8
File needs to be chmodded 755; as for the other, see twslex's post.


UBB.Dev - Putting Dev into UBB.threads
Company: VNC Web Services - UBB.threads Scripts and Scripting, Install and Upgrade Services, Site and Server Maintenance.
Forums: A Gardeners Forum, Scouters World, and UGN Security
UBB.Threads: My UBB Themes, UBB.Sitemaps
Re: [6.7] [beta] UBB.Uploader
#203113 12/13/2005 2:53 PM
Joined: Jun 2002
Posts: 111
Member
Offline
Member
Joined: Jun 2002
Posts: 111
For those of u who also are having problems with big file uploads.

i have modified the php code of JUpload to match the users/ as used in ubb_upload.cgi

feel free to ask for it.

Re: [6.7] [beta] UBB.Uploader
#203114 12/13/2005 5:52 PM
Joined: Dec 2005
Posts: 8
Junior Member
Offline
Junior Member
Joined: Dec 2005
Posts: 8
Getting closer.

Fixed the files according to the post from twslex and chmodded per Gizzy.

Reuploaded everything.

Then I got the error:
Can't locate /vars_misc.cgi in @INC (@INC contains: ./Modules .

This error was mentioned in this thread earlier and Alan Thompson found a fix described in:
https://www.ubbdev.com/ubb/ultimatebb.php/topic/33/168/8.html#000113

Found that line in ubb_upload.cgi and fixed it and reuploaded.

Now when I click the Upload File Form link I get an error of:
No such file or directory at ubb_upload.cgi line 219.

My line 219 of ubb_upload says:
mkdir($vars_misc{'upload_dir'}, SEVENSEVENSEVEN) or die $!;

I have no idea what that means so I started looking at the CP.

I changed the directory path and then got past that error. It then allowed me to browse for a file on my hard drive and 'upload' it. But when I go to view the file it's not in the directory it points me to and the file doesn't actually exist in the directory it says it is in.

Did I miss something obvious?

I'm off the cold medication so this should be easier I would think.

-elz

Re: [6.7] [beta] UBB.Uploader
#203115 12/15/2005 12:31 AM
Joined: Mar 2000
Posts: 21,079
Likes: 3
I type Like navaho
Offline
I type Like navaho
Joined: Mar 2000
Posts: 21,079
Likes: 3
It sounds like you have the directory not set correctly.... you've got to set it correctly in your control panel.


- Allen wavey
- What Drives You?
Sponsored Links
Re: [6.7] [beta] UBB.Uploader
#203116 12/15/2005 11:40 AM
Joined: Dec 2005
Posts: 8
Junior Member
Offline
Junior Member
Joined: Dec 2005
Posts: 8
you are correct sir!
you folks rule

with everyones help here I was able to get this wonderful modification up and running.

the latest problem was indeed an improperly set directory. I had it as ubbuploads and it created that directory for me in my cgi directory. course when i tried to access those files from the link provided after uploading it never gave me the right picture, file whatever. so when i changed the directory to ../html/ubbuploads it worked flawlessly

thanks again everyone. couldn't have done it without everyones help.

Re: [6.7] [beta] UBB.Uploader
#203117 01/04/2006 6:45 PM
Joined: Jan 2006
Posts: 3
Junior Member
Offline
Junior Member
Joined: Jan 2006
Posts: 3
Hi,

I've tried installing this on my UBB 6.7.3 but I keep getting 500 Internal Server Error when clicking on the Upload Form link. If I try to execute the file ubb_upload from the shell in linux, i get the error 'bad interpreter : no such file or directory'. i've changed the perl link in the top line btw to match what's in ultimatebb.cgi.

Re: [6.7] [beta] UBB.Uploader
#203118 01/04/2006 10:26 PM
Joined: Mar 2000
Posts: 21,079
Likes: 3
I type Like navaho
Offline
I type Like navaho
Joined: Mar 2000
Posts: 21,079
Likes: 3
Sounds more like either a permissions issue with the upload folder or the url/path to it is not set correctly.


- Allen wavey
- What Drives You?
Re: [6.7] [beta] UBB.Uploader
#203119 01/05/2006 5:01 AM
Joined: Jan 2006
Posts: 3
Junior Member
Offline
Junior Member
Joined: Jan 2006
Posts: 3
Well, I set the uploads directory in the control panel and I set permissions for that directory to 777 but I get the same error (500 internal server error and bad interpreter on the command line). I looked through the ubb_upload.cgi script and it looks like there's error handling for the lack of upload directory so would it crash like that ?

Re: [6.7] [beta] UBB.Uploader
#203120 01/06/2006 6:26 PM
Joined: Mar 2000
Posts: 21,079
Likes: 3
I type Like navaho
Offline
I type Like navaho
Joined: Mar 2000
Posts: 21,079
Likes: 3
hmmm... what size file are you uploading? Server limitations may be throwing the error.

You might try 755 as well, some server setups do not like 777 on directories and will automagically default them to something lower.


- Allen wavey
- What Drives You?
Sponsored Links
Re: [6.7] [beta] UBB.Uploader
#203121 01/06/2006 6:32 PM
Joined: Jan 2006
Posts: 3
Junior Member
Offline
Junior Member
Joined: Jan 2006
Posts: 3
Well, I cannot even get to the upload stage. This is the error I get when clicking on the 'Upload Form' link at the side of the post. Server permissions are definitely ok. I've tried 755 and 777. This is all on a Linux box btw.

Re: [6.7] [beta] UBB.Uploader
#203122 01/06/2006 11:40 PM
Joined: Mar 2000
Posts: 21,079
Likes: 3
I type Like navaho
Offline
I type Like navaho
Joined: Mar 2000
Posts: 21,079
Likes: 3
possibly the file is corrupt then? You might try uploading a fresh copy...


- Allen wavey
- What Drives You?
Re: [6.7] [beta] UBB.Uploader
#203123 01/31/2006 11:21 AM
Joined: Aug 2000
Posts: 178
Member
Offline
Member
Joined: Aug 2000
Posts: 178
Happy belated New Years!

Unfortunately I lack the time to read this thread in its entirety. But I noticed a slight problem and would like to resolve it.

Uploads work fine and per limits set in Control Panel until you edit a users account for any reason. Upon entering a users profile in control panel the "Do Not Allow Uploads" is checked and saved (unless I make it a point to recheck the "Use Default Group Settings".

Where would I fix this to always allow Group Settings ?

Thanks!

Re: [6.7] [beta] UBB.Uploader
#203124 02/28/2006 5:20 PM
Joined: Jan 2006
Posts: 2
Junior Member
Offline
Junior Member
Joined: Jan 2006
Posts: 2
Hey all. We're having problems similar to the ones mentioned but I'm having a difficult time following the thread to determine what our solution should be.

Here is our Messageboard:

http://talk.insidemotorsportskc.com/cgi-bin/ultimatebb.cgi

When we try to update the control panel we get the following:

Form validation errors:

: You did not enter a value for this field
: You did not enter a value for this field

I saw the earlier post about blank fields and I think I've got it covered. Here is the set up in our control panel:

[Linked Image]

Any ideas or suggestions would be excellent

thanks,

William
[email protected]

Re: [6.7] [beta] UBB.Uploader
#203125 02/28/2006 6:30 PM
Joined: Mar 2000
Posts: 21,079
Likes: 3
I type Like navaho
Offline
I type Like navaho
Joined: Mar 2000
Posts: 21,079
Likes: 3
would adding extensions in the regular files box fix it?

txt


for instance.


- Allen wavey
- What Drives You?
Re: [6.7] [beta] UBB.Uploader
#203126 03/01/2006 9:26 AM
Joined: Jan 2006
Posts: 2
Junior Member
Offline
Junior Member
Joined: Jan 2006
Posts: 2
I gave that a try and it is still giving me the same error.

Is the zip file listed at the beginning of this thread updated to include the various suggestions throughout? The updates listed throughout the thread are now broken links.

Re: [6.7] [beta] UBB.Uploader
#203127 03/03/2006 4:39 PM
Joined: Jan 2000
Posts: 5,795
Likes: 8
UBB.Dev / UBB.Wiki Owner
Time Lord
Offline
UBB.Dev / UBB.Wiki Owner
Time Lord
Joined: Jan 2000
Posts: 5,795
Likes: 8
It SHOULD be, however most authors make a comment stating "File updated to reflect changes", if there hasn't been any such post then it may not; and your only bet then would be to pm the author, if they're still around.


UBB.Dev - Putting Dev into UBB.threads
Company: VNC Web Services - UBB.threads Scripts and Scripting, Install and Upgrade Services, Site and Server Maintenance.
Forums: A Gardeners Forum, Scouters World, and UGN Security
UBB.Threads: My UBB Themes, UBB.Sitemaps
Re: [6.7] [beta] UBB.Uploader
#203128 05/18/2006 12:34 PM
Joined: Jan 2000
Posts: 236
Likes: 2
Beta Tester
Offline
Beta Tester
Joined: Jan 2000
Posts: 236
Likes: 2
I am having the same problem as SPIDERtel
using ver 6.72. It looks like the insertion of the menu items has corrupted the form. If you look at the un-hacked page and compare it to the hacked page you will notice that some of the form items are either missing or out of order.
You will need to expand the advanced list to compare them.

Re: [6.7] [beta] UBB.Uploader
#203129 05/21/2006 11:15 PM
Joined: Mar 2000
Posts: 21,079
Likes: 3
I type Like navaho
Offline
I type Like navaho
Joined: Mar 2000
Posts: 21,079
Likes: 3
Here's the current files with all bugs I could find within the topic fixed: https://www.ubbdev.com/ubb/upload/00000494/Uploader6.7.3.zip

It was just 1-2 buglets, I was hoping to make sure there weren't any missed. Brett, feel free to check it out and update the original post with your checked files smile

Ruben, this has been tested on 6.7.2 and 6.7.3, should work for you.


- Allen wavey
- What Drives You?
Re: [6.7] [beta] UBB.Uploader
#203130 06/12/2006 1:31 PM
Joined: Jan 2000
Posts: 236
Likes: 2
Beta Tester
Offline
Beta Tester
Joined: Jan 2000
Posts: 236
Likes: 2
I tried the new file and most of the form fields in the control panel are correct now but I can't upload a file . The field in the control panel for regular file types I put in jpg but the field remains yellow when submitted.
When I try to upload a jpg file I get
Quote
quote:
FYI
You are trying to upload something with an illegal extentsion. The currently allowed are: .jpg, gif, and you tried to upload a file(s).
I checked the vars_misc file and the type is listed. Also it made a folder with the user number in the correct location but the file was not there.

I have tried .jpg jpg JPG no luck for allowed file types

Re: [6.7] [beta] UBB.Uploader
#203131 06/12/2006 9:43 PM
Joined: Mar 2000
Posts: 21,079
Likes: 3
I type Like navaho
Offline
I type Like navaho
Joined: Mar 2000
Posts: 21,079
Likes: 3
odd, what kind of server?


- Allen wavey
- What Drives You?
Re: [6.7] [beta] UBB.Uploader
#203132 06/13/2006 5:21 AM
Joined: Jan 2000
Posts: 236
Likes: 2
Beta Tester
Offline
Beta Tester
Joined: Jan 2000
Posts: 236
Likes: 2
The server is windows 2003
I installed a fresh unhacked copy of UBB.classicâ„¢ 6.7.2 in a seperate folder
before I installed this mod.

Update
I installed the old version of the upload hack and even though the control panel form is hosed it works fine so I don't think it is a server file permission. Is there something I can check in the vars files between the two versions? or possibly the new upload cgi file?

Re: [6.7] [beta] UBB.Uploader
#203133 06/13/2006 10:33 AM
Joined: Mar 2000
Posts: 21,079
Likes: 3
I type Like navaho
Offline
I type Like navaho
Joined: Mar 2000
Posts: 21,079
Likes: 3
A file compare would help. Do you have a copy of the old stuff?


- Allen wavey
- What Drives You?
Re: [6.7] [beta] UBB.Uploader
#203134 06/13/2006 10:56 AM
Joined: Jan 2000
Posts: 236
Likes: 2
Beta Tester
Offline
Beta Tester
Joined: Jan 2000
Posts: 236
Likes: 2
I have the old and new hacks and the old and new hacked files for ubb. I am not sure what to look for in a file comepare other that there are some differences in the script and the hack instructions

Re: [6.7] [beta] UBB.Uploader
#203135 06/13/2006 8:25 PM
Joined: Mar 2000
Posts: 21,079
Likes: 3
I type Like navaho
Offline
I type Like navaho
Joined: Mar 2000
Posts: 21,079
Likes: 3
Post the old here and I'll compare. Did you use the version I said was for windows servers?


- Allen wavey
- What Drives You?
Re: [6.7] [beta] UBB.Uploader
#203136 06/13/2006 9:03 PM
Joined: Mar 2000
Posts: 21,079
Likes: 3
I type Like navaho
Offline
I type Like navaho
Joined: Mar 2000
Posts: 21,079
Likes: 3


- Allen wavey
- What Drives You?
Re: [6.7] [beta] UBB.Uploader
#203137 06/14/2006 3:47 PM
Joined: Jan 2000
Posts: 236
Likes: 2
Beta Tester
Offline
Beta Tester
Joined: Jan 2000
Posts: 236
Likes: 2
Duh!
That works. I thought the link you provided fixed it all.
So uploader 6.7.3 fixed the control panel and the windows version uploader.cgi script fixed the upload problem.
Thank you!
Now my new problem I will post in the new members forum.
I turned on the custom avatars option and it does not appear to work, even on the unhacked board.
Thank you again Allen

Re: [6.7] [beta] UBB.Uploader
#203138 06/14/2006 4:05 PM
Joined: Mar 2000
Posts: 21,079
Likes: 3
I type Like navaho
Offline
I type Like navaho
Joined: Mar 2000
Posts: 21,079
Likes: 3
You're welcome, uploads work differently on windows servers smile


- Allen wavey
- What Drives You?
Re: [6.7] [beta] UBB.Uploader
AllenAyres #310972 07/31/2006 2:41 PM
Joined: Dec 2004
Posts: 5
Lurker
Offline
Lurker
Joined: Dec 2004
Posts: 5
Just wanted to thank Brett for this great program, plus AllenAyres et al for their helping people install it.

GREAT program.

Re: [6.7] [beta] UBB.Uploader
mrlumpy #311035 08/03/2006 12:51 PM
Joined: Mar 2000
Posts: 21,079
Likes: 3
I type Like navaho
Offline
I type Like navaho
Joined: Mar 2000
Posts: 21,079
Likes: 3
You're welcome smile


- Allen wavey
- What Drives You?
Re: [6.7] [beta] UBB.Uploader
Webberver1 #311426 09/03/2006 1:39 PM
Joined: Dec 2003
Posts: 49
User
Offline
User
Joined: Dec 2003
Posts: 49
Is there a way to allow specific users a different Maximum # Of Files instead of the group option?

For example, I want member 00000387 to be able to upload 10 files rather than his group's 5 files max.

(Please ignore this post, I was attempting to use infor there to do what I wanted and it didn't work out. I should have paid attention to where I was.)

Re: [6.7] [beta] UBB.Uploader
Nightcrawler #318049 08/05/2009 2:53 PM
Joined: Aug 2009
Posts: 13
Newbie
Offline
Newbie
Joined: Aug 2009
Posts: 13
I don't know if these threads are still monitored but I've got few options so here goes.

I'm trying to install this, going through my cgi-bin adding code as described in the install notes. Now it's asking me to find a file named cp2_forums2.cgi

There is no such file. I'm using UBB classic 6.7.1

Don't think it's beta. Can I skip this file? If not, what do I do?

Thanks you much,

Shant

Re: [6.7] [beta] UBB.Uploader
Ian Spence #318050 08/05/2009 3:17 PM
Joined: Jan 2000
Posts: 236
Likes: 2
Beta Tester
Offline
Beta Tester
Joined: Jan 2000
Posts: 236
Likes: 2
Originally Posted by Ian Spence
this mod is for 6.7, cp2_forums.cgi is the file, must have been a typo
Okay Shant you should see this in the topic you posted in. So It appears that it was a typo in the instructions.
In lieu of cp2_forums2.cgi.
Probably was due to a older version of classic used the 2 file or a older version of this mod had a 2 file.

Re: [6.7] [beta] UBB.Uploader
Ruben Rocha #318051 08/05/2009 3:39 PM
Joined: Aug 2009
Posts: 13
Newbie
Offline
Newbie
Joined: Aug 2009
Posts: 13
HA! I knew something was off and it wasn't on my end. You're the best mate.

Re: [6.7] [beta] UBB.Uploader
Shant #318052 08/05/2009 3:42 PM
Joined: Jan 2000
Posts: 236
Likes: 2
Beta Tester
Offline
Beta Tester
Joined: Jan 2000
Posts: 236
Likes: 2
See,All I needed was to figure out what mod you were using. If you read the 10 pages on this topic you will see it.
Good luck!

Re: [6.7] [beta] UBB.Uploader
Ruben Rocha #318054 08/05/2009 5:43 PM
Joined: Aug 2009
Posts: 13
Newbie
Offline
Newbie
Joined: Aug 2009
Posts: 13
OK, now I've run into the "infamous" 404 error thing. I thought I did everything right. All the new options show up in the control panel.

What should 'upload path' and 'upload' url be set to? Should they both be in url format?

Re: [6.7] [beta] UBB.Uploader
Shant #318055 08/06/2009 9:27 AM
Joined: Aug 2009
Posts: 13
Newbie
Offline
Newbie
Joined: Aug 2009
Posts: 13
Also, I've read throughout the thread mention made to a file named ubb_upload.cgi

There is no such file in my cgi-bin. I tried the link in this thread to re-upload it, it's dead.


Re: [6.7] [beta] UBB.Uploader
Shant #318056 08/06/2009 1:15 PM
Joined: Jan 2000
Posts: 236
Likes: 2
Beta Tester
Offline
Beta Tester
Joined: Jan 2000
Posts: 236
Likes: 2
Okay first the file ubb_upload.cgi is in the zip file you downloaded. You need to upload that to the ubb directory.
As far as paths and urls. look in your control panel for a clue on what you path and url is to your forum.
url will be something like http://www.yoursite.com/cgi_bin/ubb
Path will look something like /home/public_html/cgi_bin/ubb
I am assuming you are on a linux host. If you are on windows then your path will be formatted a little different.
Like I said look in your ubb control panel for what your board path&url settings are now and just copy them and adjust them if needed.

I just down loaded the link here and it works fine. Maybe something was down at the time.

Re: [6.7] [beta] UBB.Uploader
Ruben Rocha #318057 08/06/2009 6:04 PM
Joined: Aug 2009
Posts: 13
Newbie
Offline
Newbie
Joined: Aug 2009
Posts: 13
Ah yes you're right, as usual, the file was in the zip I downloaded. It was another link I tried on page 2 or 3 that failed.

OK, so I uploaded it to the ubb directory, no effect. I uploaded it to the cgi-bin. Now I get another error:

"Forbidden
You don't have permission to access /cgi-bin/ubb_upload.cgi on this server."

All the permissions and what not have been set properly in the "primary settings" tab at the control panel. Every field has been filled in the upload settings tab.

Is this a server issue? Are we talking about the server my host uses?


Re: [6.7] [beta] UBB.Uploader
Shant #318058 08/06/2009 6:21 PM
Joined: Jan 2000
Posts: 5,795
Likes: 8
UBB.Dev / UBB.Wiki Owner
Time Lord
Offline
UBB.Dev / UBB.Wiki Owner
Time Lord
Joined: Jan 2000
Posts: 5,795
Likes: 8
Did you chmod the file 755? A forbidden error would generally be spewed due to server-side permissions on files.


UBB.Dev - Putting Dev into UBB.threads
Company: VNC Web Services - UBB.threads Scripts and Scripting, Install and Upgrade Services, Site and Server Maintenance.
Forums: A Gardeners Forum, Scouters World, and UGN Security
UBB.Threads: My UBB Themes, UBB.Sitemaps
Page 5 of 6 1 2 3 4 5 6

Link Copied to Clipboard
Donate Today!
Donate via PayPal

Donate to UBBDev today to help aid in Operational, Server and Script Maintenance, and Development costs.

Please also see our parent organization VNC Web Services if you're in the need of a new UBB.threads Install or Upgrade, Site/Server Migrations, or Security and Coding Services.
Recommended Hosts
We have personally worked with and recommend the following Web Hosts:
Stable Host
bluehost
InterServer
Visit us on Facebook
Member Spotlight
Pilgrim
Pilgrim
NH, USA
Posts: 190
Joined: June 2000
Forum Statistics
Forums63
Topics37,529
Posts293,721
Members13,834
Most Online5,166
Sep 15th, 2019
Today's Statistics
Currently Online 154
Topics Created 0
Posts Made 0
Users Online 2
Birthdays 20
Top Posters
AllenAyres 21,079
JoshPet 10,369
LK 7,394
Lord Dexter 6,708
Gizmo 5,795
Greg Hard 4,625
Top Posters(30 Days)
isaac 3
Top Likes Received
isaac 33
Gizmo 8
Brett 7
Morgan 2
Top Likes Received (30 Days)
isaac 3
The UBB.Developers Network (UBB.Dev/Threads.Dev) is ©2000-2020 VNC Web Services

 
Powered by UBB.threads™ PHP Forum Software 7.7.4
(Snapshot build 20200219.dev)
Responsive Width:

PHP: 5.4.45 Page Time: 0.118s Queries: 96 (0.057s) Memory: 3.6517 MB (Peak: 4.0801 MB) Data Comp: Zlib Server Time: 2020-02-20 10:47:44 UTC
Valid HTML 5 and Valid CSS