Previous Thread
Next Thread
Print Thread
Rating: 5
Page 2 of 3 1 2 3
Re: Finished-[6.4-6.5] Feature Shop 1.6
luan #281115 01/23/2005 7:16 AM
Joined: Feb 2003
Posts: 196
Member
Offline
Member
Joined: Feb 2003
Posts: 196
Ok I think I am done.

One last thing, when I do the cahnge user name feature and try to do the preview thingi, it doesnt work, it gives me an error page of 404 or something. Why?

Sponsored Links
Re: Finished-[6.4-6.5] Feature Shop 1.6
me_oh_my #281116 01/23/2005 12:07 PM
Joined: Oct 2003
Posts: 2,305
Old Hand
OP Offline
Old Hand
Joined: Oct 2003
Posts: 2,305
cause I was dumb and left out one file download the zip again and just copy over the itempreview.php

Re: Finished-[6.4-6.5] Feature Shop 1.6
234234 #281117 01/23/2005 8:48 PM
Joined: Jan 2005
Posts: 39
User
Offline
User
Joined: Jan 2005
Posts: 39
I downloaded the attachment of this progie from your original post. But the instructions65.txt file and title of this .txt file makes reference to UBB.Threads v6.5. I need a confirmation from you (scroungr) that I can use this on v6.4.

Thank You!

Re: Finished-[6.4-6.5] Feature Shop 1.6
Pumpkihn #281118 01/24/2005 12:15 AM
Joined: Oct 2003
Posts: 2,305
Old Hand
OP Offline
Old Hand
Joined: Oct 2003
Posts: 2,305
you can but you may need to do a little rewrite. the mod basically doesn't get much from the ubthreads but the placements of the points system into threads script files won't be the same for 6.5 to 6.4. One of the other users here is using this mod with v6.4.

Re: Finished-[6.4-6.5] Feature Shop 1.6
234234 #281119 01/24/2005 11:48 PM
Joined: Feb 2003
Posts: 196
Member
Offline
Member
Joined: Feb 2003
Posts: 196
ok, EXCELLENT thanks dude

Sponsored Links
Re: Finished-[6.4-6.5] Feature Shop 1.6
square_peg #281120 01/25/2005 12:13 AM
Joined: Feb 2003
Posts: 196
Member
Offline
Member
Joined: Feb 2003
Posts: 196
scroungr,

why is it I find difficult changing the color and glowing for my username.

I gave myself so many points so I can play with the feature, but everytime I try to change color and give glowing it doesnt do it. Why? Help?

Re: Finished-[6.4-6.5] Feature Shop 1.6
me_oh_my #281121 01/25/2005 12:38 AM
Joined: Feb 2003
Posts: 196
Member
Offline
Member
Joined: Feb 2003
Posts: 196
for some reason I have problem with the glowing feature the most

Re: Finished-[6.4-6.5] Feature Shop 1.6
me_oh_my #281122 01/25/2005 9:37 AM
Joined: Oct 2003
Posts: 2,305
Old Hand
OP Offline
Old Hand
Joined: Oct 2003
Posts: 2,305
look into the ShopMembers table and make sure a value was placed into the glow field. Also check your placement of the string in showflat that allows the item to be viewed. let me know if it's NOT getting added into the ShopMembers table or if it's just being shown.

Re: Finished-[6.4-6.5] Feature Shop 1.6
234234 #281123 01/27/2005 11:42 PM
Joined: Feb 2003
Posts: 196
Member
Offline
Member
Joined: Feb 2003
Posts: 196
I did check the shopmembers table and I applied the value, but still its a problem.

And what do you mean placement of the string in showflat, please explain slowly, i am still learning

Re: Finished-[6.4-6.5] Feature Shop 1.6
me_oh_my #281124 01/28/2005 12:04 AM
Joined: Feb 2003
Posts: 196
Member
Offline
Member
Joined: Feb 2003
Posts: 196
scroungr,

this what I see in my shopmembers, tell me if you see anything wrong and where I should change it and what next

Last edited by scroungr; 03/02/2005 6:31 PM.
Sponsored Links
Re: Finished-[6.4-6.5] Feature Shop 1.6
me_oh_my #281125 01/28/2005 8:42 AM
Joined: Oct 2003
Posts: 2,305
Old Hand
OP Offline
Old Hand
Joined: Oct 2003
Posts: 2,305
no not the table structure let me see what one of the table entries looks like..

and I mean you have to alter the showflat.php and showthread.php and tmpls.

you should go back to the instructions and reread them and follow them closely. if you need assistance shoot me a PM with FTP access information and I will take a look.

Re: Finished-[6.4-6.5] Feature Shop 1.6
234234 #281126 01/28/2005 12:21 PM
Joined: Feb 2003
Posts: 196
Member
Offline
Member
Joined: Feb 2003
Posts: 196
thanks scroungr, I will send you the ftp access, appreciate it thanks

Re: Finished-[6.4-6.5] Feature Shop 1.6
me_oh_my #281127 01/28/2005 5:14 PM
Joined: Oct 2003
Posts: 2,305
Old Hand
OP Offline
Old Hand
Joined: Oct 2003
Posts: 2,305
Salim what issues were you having? I saw a few changes people made? did you have under your

Display preferences, number of shown topics, languages, colors...

View Special Effects in User's names and Titles Purchased from the Feature Shop

set to yes?

Re: Finished-[6.4-6.5] Feature Shop 1.6
234234 #281128 01/29/2005 12:09 AM
Joined: Feb 2003
Posts: 196
Member
Offline
Member
Joined: Feb 2003
Posts: 196
ooopppps, scorungr, you should have mentioned that I needed to switch the effect in my profile duhhhhhhhhhhh

Sorry my mistake and thanks a bunch fory our help. you are da man

Re: Finished-[6.4-6.5] Feature Shop 1.6
me_oh_my #281129 03/02/2005 4:03 PM
Joined: Aug 2004
Posts: 173
Member
Offline
Member
Joined: Aug 2004
Posts: 173
I had this working for a few weeks with no problems then one user said they had this problem

[]http://www.parentforum.org/ubbthreads/Attachments/4202-leannprtsc.jpg.jpg[/]
Then another member had the same problem. But I could not find anything wrong on when I looked. I uploaded my pre feature shop showflat.php and the fault stopped.
I followed the the install instructions again and uploaded the file I had the same error which I saw this time

I have attached my version on showflat.php if someone could have a look at it and point out if I have made a mistake.


Last edited by scroungr; 03/02/2005 6:31 PM.
Re: Finished-[6.4-6.5] Feature Shop 1.6
DMClark #281130 03/02/2005 4:17 PM
Joined: Oct 2003
Posts: 2,305
Old Hand
OP Offline
Old Hand
Joined: Oct 2003
Posts: 2,305
whats the error say?

Re: Finished-[6.4-6.5] Feature Shop 1.6
234234 #281131 03/02/2005 4:33 PM
Joined: Aug 2004
Posts: 173
Member
Offline
Member
Joined: Aug 2004
Posts: 173
[]scroungr said:
whats the error say? [/]

It does not say anything, it makes posts look like my picture above

Re: Finished-[6.4-6.5] Feature Shop 1.6
234234 #281132 03/02/2005 4:36 PM
Joined: Feb 2002
Posts: 2,286
Veteran
Offline
Veteran
Joined: Feb 2002
Posts: 2,286
Looks like you have a missing cell or table closure.

When I get similar, I dump the source code from that page into FrontPage - fix the error - then alter the template, with the same modification.


Fans Focus - Focusing on Fans of Sport

(Okay - mainly football (the British variety wink at the moment - but expanding all the time....)
Re: Finished-[6.4-6.5] Feature Shop 1.6
Gorlum #281133 03/02/2005 5:57 PM
Joined: Aug 2004
Posts: 173
Member
Offline
Member
Joined: Aug 2004
Posts: 173
I don't have frontpage

Re: Finished-[6.4-6.5] Feature Shop 1.6
DMClark #281134 03/02/2005 6:11 PM
Joined: Oct 2003
Posts: 2,305
Old Hand
OP Offline
Old Hand
Joined: Oct 2003
Posts: 2,305
definitily a table issue.. hows it look in threaded mode? could also be the .tmpl as well as the .php?

Re: Finished-[6.4-6.5] Feature Shop 1.6
234234 #281135 03/02/2005 6:15 PM
Joined: Oct 2003
Posts: 2,305
Old Hand
OP Offline
Old Hand
Joined: Oct 2003
Posts: 2,305
actually looking back over this coding I would figure its more in the .php then in the .tmpl. with all the spanning and diving going on could be the issue.

Re: Finished-[6.4-6.5] Feature Shop 1.6
234234 #281136 03/02/2005 6:33 PM
Joined: Oct 2003
Posts: 2,305
Old Hand
OP Offline
Old Hand
Joined: Oct 2003
Posts: 2,305
okay had to remove the showflat.php.. site rulez say don't post full file.. you can post code snipets.. anyways I checked you file and it works on my site but I noticed on the bottom of the showflat.php that you have

// Adsense hack start
$adsense = "";
if ( stristr(",{$config['adsense']},", ",$Board,") ) {
include("$thispath/templates/$tempstyle/adsense.tmpl");
}
// Adsense hack finish


try removing those lines and retest.. you MAY have a problem in the adsense.tmpl

Re: Finished-[6.4-6.5] Feature Shop 1.6
234234 #281137 03/03/2005 1:37 AM
Joined: Aug 2004
Posts: 173
Member
Offline
Member
Joined: Aug 2004
Posts: 173
[]scroungr said:
okay had to remove the showflat.php.. site rulez say don't post full file.. you can post code snipets.. anyways I checked you file and it works on my site but I noticed on the bottom of the showflat.php that you have

// Adsense hack start
$adsense = "";
if ( stristr(",{$config['adsense']},", ",$Board,") ) {
include("$thispath/templates/$tempstyle/adsense.tmpl");
}
// Adsense hack finish


try removing those lines and retest.. you MAY have a problem in the adsense.tmpl [/]

I will try that and let you know

[] site rulez say don't post full file.. [/]

Re: Finished-[6.4-6.5] Feature Shop 1.6
DMClark #281138 03/03/2005 8:53 PM
Joined: Oct 2003
Posts: 2,305
Old Hand
OP Offline
Old Hand
Joined: Oct 2003
Posts: 2,305
okay the problem is you are allowing html in the signature.. so you cannot use the signature part as this is written.. you will need to disbale the signature stuff in the shop and in showflat.php change

Code
	// ------------------------- <br />// Build Board Query For Shop Mod & Show Funky Names <br />		$query=" <br />			SELECT titleeffectstatus <br />			FROM {$config['tbprefix']}ShopMembers <br />			WHERE uid = '$user[U_Number]' <br />		"; <br />	   	$stq = $dbh -> do_query($query); <br />		list($titleeffectstatus)= $dbh -> fetch_array($stq); <br />		$query=" <br />			SELECT glowcolor,titleeffect,hexcolor, cstatus, imagesignature, largersignature, avatar <br />			FROM {$config['tbprefix']}ShopMembers,{$config['tbprefix']}Users <br />			WHERE U_Number = '$usernum' && U_Number = uid <br />		"; <br />	   	$stz = $dbh -> do_query($query); <br />		list($glowcolor, $titleeffect, $hexcolor, $cstatus, $imagesignature, $largersignature, $newavatar)= $dbh -> fetch_array($stz); <br /> <br />		if ($config['sigimage']){ <br /> <br />			if ($Signature) { <br />				$Signature = str_replace("\n","<br />",$Signature); <br />				$Signature = "<br /><br />--------------------<br />$Signature"; <br />			} <br />			if ($ShowSigs == "no" || !$addsig) { <br />				$Signature = ""; <br />			} <br />		} <br />		else{ <br />			if ($imagesignature != 'ON') { <br />				$Signature = preg_replace("/<img src=\"([^\>]*)\">/i","",$Signature); <br />			} <br />			if ($largersignature != 'ON' && $imagesignature == 'ON') { <br />				preg_match("/signature\/[[:alnum:]]{3,40}\.[[:alnum:]]{3,4}/i",$Signature,$matches); <br />				if($matches){ <br />					$Signature = "<img src=\"{$config['imageurl']}/$matches[0]\">"; <br />				} <br />				else{ <br />					$Signature = substr($Signature, 0, $config['Sig_length']); <br />				} <br />			} <br />			elseif ($largersignature != 'ON' && $imagesignature != 'ON') { <br />				$Signature = substr($Signature, 0, $config['Sig_length']); <br />			} <br />			if($Signature){ <br />				$Signature = str_replace("\n","<br />",$Signature); <br />				$Signature = "<br /><br />--------------------<br />$Signature"; <br />			} <br />		} <br />// End Build Board Query For Shop Mod & Show Funky Names <br />// ------------------------- <br />		}



to


Code
 <br />// ------------------------- <br />// Build Board Query For Shop Mod & Show Funky Names <br />		$query=" <br />			SELECT titleeffectstatus <br />			FROM {$config['tbprefix']}ShopMembers <br />			WHERE uid = '$user[U_Number]' <br />		"; <br />	   	$stq = $dbh -> do_query($query); <br />		list($titleeffectstatus)= $dbh -> fetch_array($stq); <br />		$query=" <br />			SELECT glowcolor,titleeffect,hexcolor, cstatus, imagesignature, largersignature, avatar <br />			FROM {$config['tbprefix']}ShopMembers,{$config['tbprefix']}Users <br />			WHERE U_Number = '$usernum' && U_Number = uid <br />		"; <br />	   	$stz = $dbh -> do_query($query); <br />		list($glowcolor, $titleeffect, $hexcolor, $cstatus, $imagesignature, $largersignature, $newavatar)= $dbh -> fetch_array($stz); <br /> <br />// End Build Board Query For Shop Mod & Show Funky Names <br />// ------------------------- <br />



in the showflat.php that will set it back to the stock except for the signature

Last edited by scroungr; 03/03/2005 8:57 PM.
Re: Finished-[6.4-6.5] Feature Shop 1.6
234234 #281139 03/05/2005 7:12 PM
Joined: Aug 2004
Posts: 173
Member
Offline
Member
Joined: Aug 2004
Posts: 173
Thank you scroungr for this and your time the other day.
I have not had time to try this out yet. Will let you know if it is all ok.


Re: Finished-[6.4-6.5] Feature Shop 1.6
DMClark #281140 03/06/2005 12:38 PM
Joined: Oct 2003
Posts: 2,305
Old Hand
OP Offline
Old Hand
Joined: Oct 2003
Posts: 2,305
yeah cause your using html and graemlins in your sigs ad I limited the mechanism so it only allows one image per person it won't work without a major rewrite...so its best to leave out the signature stuff in your usuage.. the rest should work.. the shadowed names, the glowing names, and all the rest of the abilities...

Re: Finished-[6.4-6.5] Feature Shop 1.6
234234 #281141 03/06/2005 2:44 PM
Joined: Jun 2002
Posts: 670
Code Monkey
Offline
Code Monkey
Joined: Jun 2002
Posts: 670
I've just installed this and I have some issues/questions:
What all do I need to do to make this work? I have turned off the display name changes and images in the signature. What do I have to do for the reset signature and the larger signature items to work?

Also, I'm having issues with the templates:
It looks ok here, but it's not:
http://www.laondalatina.com/foros/shop.php
Because on the rest of the site, I have a vertical bar on the right where I plan to add content:
http://www.laondalatina.com/foros/
I believe there is an issue with missing table tags.
Here it gets hairy:
http://www.laondalatina.com/foros/shopcategory.php?Cat=&cid=1
Probably another template issue.

Finally, when I go to the Shop Admin area, nothing happens when I click on Categories, Items, Add Points, Show User Stats. It keeps bringing me back to the settings screen.

Any suggestions?

Re: Finished-[6.4-6.5] Feature Shop 1.6
luan #281142 03/07/2005 2:15 AM
Joined: Oct 2003
Posts: 2,305
Old Hand
OP Offline
Old Hand
Joined: Oct 2003
Posts: 2,305
I will take a look in the morning at the code. I see a possible problem.

Re: Finished-[6.4-6.5] Feature Shop 1.6
234234 #281143 03/07/2005 8:36 PM
Joined: Oct 2003
Posts: 2,305
Old Hand
OP Offline
Old Hand
Joined: Oct 2003
Posts: 2,305
okay uploaded a new zip.. should fix some of the issues...

Re: Finished-[6.4-6.5] Feature Shop 1.6
234234 #281144 03/08/2005 8:07 PM
Joined: Jun 2002
Posts: 670
Code Monkey
Offline
Code Monkey
Joined: Jun 2002
Posts: 670
I haven't uploaded ALL the new files, but I did update the 6.5 .php files and the templates, and everything looks the same.

Re: Finished-[6.4-6.5] Feature Shop 1.6
luan #281145 03/09/2005 2:01 AM
Joined: Oct 2003
Posts: 2,305
Old Hand
OP Offline
Old Hand
Joined: Oct 2003
Posts: 2,305
Hmmm I see this error

SQL Error: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near ') ORDER BY displayorder, catname' at line 4
SQL Error #: 1064
Query: SELECT * FROM w3t_ShopCats WHERE cid='0' AND (status = 'on' || owner = ) ORDER BY displayorder, catname

and you can't have the new files if your still getting that error cause I fixed it?

Re: Finished-[6.4-6.5] Feature Shop 1.6
234234 #281146 03/09/2005 12:24 PM
Joined: Jun 2002
Posts: 670
Code Monkey
Offline
Code Monkey
Joined: Jun 2002
Posts: 670
[]scroungr said:
Hmmm I see this error

SQL Error: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near ') ORDER BY displayorder, catname' at line 4
SQL Error #: 1064
Query: SELECT * FROM w3t_ShopCats WHERE cid='0' AND (status = 'on' || owner = ) ORDER BY displayorder, catname

and you can't have the new files if your still getting that error cause I fixed it? [/]

What script did you see that error on? I don't see it. Another problem I've noticed is that when I click on Bank, it tells me how many points I have. Though when I click on any of the links on that page (Finances, Credit, Debit, Send Points) the URL changes, but the actual content on the page doesn't. Every link takes me nowhere, or better put, I stay at the page that says how many points I have.

Re: Finished-[6.4-6.5] Feature Shop 1.6
luan #281147 03/09/2005 3:17 PM
Joined: Oct 2003
Posts: 2,305
Old Hand
OP Offline
Old Hand
Joined: Oct 2003
Posts: 2,305
Hmmm send me a PM with some login information I wanna check a few things

Re: Finished-[6.4-6.5] Feature Shop 1.6
234234 #281148 03/09/2005 6:35 PM
Joined: Jun 2002
Posts: 670
Code Monkey
Offline
Code Monkey
Joined: Jun 2002
Posts: 670
Let me go create a new admin and I'll PM you the info.

Re: Finished-[6.4-6.5] Feature Shop 1.6
luan #281149 03/10/2005 9:54 AM
Joined: Oct 2003
Posts: 2,305
Old Hand
OP Offline
Old Hand
Joined: Oct 2003
Posts: 2,305
ok think I see what ya did... 1) delete all the existing shopfiles.. download new zip.. the way I rewrote it all the shop files will be placed in a director called theshop to be placed inside the threads directory.... I took the files out of languages and templates and moved em all inside the directory so it will make it easier to update and vice-a-versa

Re: Finished-[6.4-6.5] Feature Shop 1.6
234234 #281150 03/10/2005 12:47 PM
Joined: Jun 2002
Posts: 670
Code Monkey
Offline
Code Monkey
Joined: Jun 2002
Posts: 670
I uploaded the new .zip to the threads directory and unzipped it there and now all the files are in the /theshop directory. It still doesn't appear to have changed anything. The layout is broken by the shop on all the pages, except strangely enough, the admin area. In the admin area and the bank area, none of the links do anything either.

Re: Finished-[6.4-6.5] Feature Shop 1.6
luan #281151 03/10/2005 9:40 PM
Joined: Oct 2003
Posts: 2,305
Old Hand
OP Offline
Old Hand
Joined: Oct 2003
Posts: 2,305
hmm okay I will log in and take a look

Re: Finished-[6.4-6.5] Feature Shop 1.6
234234 #281152 03/10/2005 11:45 PM
Joined: Oct 2003
Posts: 2,305
Old Hand
OP Offline
Old Hand
Joined: Oct 2003
Posts: 2,305
okay a few questions.. do you have globals turned on or off? does your server allow the super globals $_POST and instead makes you use the obsolete $HTTP_POST_VARS and $HTTP_GET_VARS instead?

about the tables its only when you go into say the features table from what I see... that splits the table the features are lsited on and puts it below the menu you have on the right? try this shopcategory.tmpl and let me know if it fixes it.. I think there was an extra </table> closure...

Attached Files
125995-shopcategory.tmpl.txt (0 Bytes, 115 downloads)
Re: Finished-[6.4-6.5] Feature Shop 1.6
234234 #281153 03/11/2005 12:11 AM
Joined: Oct 2003
Posts: 2,305
Old Hand
OP Offline
Old Hand
Joined: Oct 2003
Posts: 2,305
BTW if your server can't use SUPER Globas $_POST and $_GET try adding this to the top of the scripts.. MAY work

// FORCE USE OF GLOBAL VARIABLES
$version_info = explode('.', phpversion());
if ($version_info[0] < 4 || ($version_info[0] > 3 && $version_info[1] < 1)) {
$_POST = $HTTP_POST_VARS;
$_GET = $HTTP_GET_VARS;
}


then again this could fail because your server won't allow the phpversion() command...

Re: Finished-[6.4-6.5] Feature Shop 1.6
234234 #281154 03/11/2005 11:11 AM
Joined: Jun 2002
Posts: 670
Code Monkey
Offline
Code Monkey
Joined: Jun 2002
Posts: 670
[]scroungr said:
okay a few questions.. do you have globals turned on or off? does your server allow the super globals $_POST and instead makes you use the obsolete $HTTP_POST_VARS and $HTTP_GET_VARS instead?

about the tables its only when you go into say the features table from what I see... that splits the table the features are lsited on and puts it below the menu you have on the right? try this shopcategory.tmpl and let me know if it fixes it.. I think there was an extra </table> closure... [/]

I'm not sure where to find the information regarding globals, so I'll ask Josh, since my site's on one of his servers Thanks, scroungr. Hopefully we'll get this thing fixed. I'm glad it wasn't just my imagination.

Page 2 of 3 1 2 3

Link Copied to Clipboard
Donate Today!
Donate via PayPal

Donate to UBBDev today to help aid in Operational, Server and Script Maintenance, and Development costs.

Please also see our parent organization VNC Web Services if you're in the need of a new UBB.threads Install or Upgrade, Site/Server Migrations, or Security and Coding Services.
Recommended Hosts
We have personally worked with and recommend the following Web Hosts:
Stable Host
bluehost
InterServer
Visit us on Facebook
Member Spotlight
Pilgrim
Pilgrim
NH, USA
Posts: 190
Joined: June 2000
Forum Statistics
Forums63
Topics37,543
Posts293,773
Members13,838
Most Online5,166
Sep 15th, 2019
Today's Statistics
Currently Online 339
Topics Created 0
Posts Made 1
Users Online 3
Birthdays 28
Top Posters
AllenAyres 21,079
JoshPet 10,369
LK 7,394
Lord Dexter 6,708
Gizmo 5,805
Greg Hard 4,625
Top Posters(30 Days)
Gizmo 9
isaac 8
driv 2
temp 2
Morgan 1
Top Likes Received
isaac 38
Gizmo 10
Brett 7
Morgan 2
Top Likes Received (30 Days)
isaac 4
Gizmo 2
The UBB.Developers Network (UBB.Dev/Threads.Dev) is ©2000-2020 VNC Web Services

 
Powered by UBB.threads™ PHP Forum Software 7.7.5
(Snapshot build 20200524.dev)
Responsive Width:

PHP: 5.4.45 Page Time: 0.104s Queries: 97 (0.025s) Memory: 3.6536 MB (Peak: 4.1073 MB) Data Comp: Zlib Server Time: 2020-05-29 00:28:09 UTC
Valid HTML 5 and Valid CSS