Previous Thread
Next Thread
Print Thread
Rating: 5
Page 8 of 11 1 2 6 7 8 9 10 11
Re: Error on the Entrace page at "Last Seen"
mrnocal #276592 12/31/2004 1:59 AM
Joined: Oct 2003
Posts: 2,305
Old Hand
OP Offline
Old Hand
Joined: Oct 2003
Posts: 2,305
ehm throw this into your sql query zone either in the control panel or is you use phpMyAdmin in that and see what it goves you

SELECT U_Username,U_LastSeen,U_Number,U_Visible
FROM w3t_Users
WHERE U_LastSeen <> U_Registered
AND U_LastSeen IS NOT NULL
AND U_Number > 1
ORDER BY U_LastSeen DESC
LIMIT 10

and

SELECT U_Username,U_Laston,U_Number,U_Visible
FROM w3t_Users
WHERE U_Laston <> U_Registered
AND U_Laston IS NOT NULL
AND U_Number > 1
ORDER BY U_Laston DESC
LIMIT 10

also in your configpal.inc.php tell me what value is in

$configpal[moreSeen]
$configpal[lastonDisplayNum]
$configpal[modifiedlastseen]

Sponsored Links
Re: Internal Server Error
#276593 01/10/2005 10:18 AM
Joined: Dec 2004
Posts: 4
Lurker
Offline
Lurker
Joined: Dec 2004
Posts: 4
I finally found out where the problem was coming from.
The problem is with [:"red"]newspal.php[/].
When I set-up IIP to pull news from more than 1 board on my forum, I get "Internal Server Error" error on the entrance page (index.php). If it is set-up to pull new from only 1 board the entrance page works fine.

Re: Internal Server Error
#276594 01/10/2005 9:28 PM
Joined: Oct 2003
Posts: 2,305
Old Hand
OP Offline
Old Hand
Joined: Oct 2003
Posts: 2,305
really? works fine for me.. wonder what it could be

Re: Internal Server Error
234234 #276595 01/17/2005 2:38 PM
Joined: Dec 2004
Posts: 4
Lurker
Offline
Lurker
Joined: Dec 2004
Posts: 4
I've identified the real source of the problem with newspal.php. It can only read from the first board on my forum (to be specific, the first board in w3t_Boards). Any attempt to pull articles from the remaining boards (2 to 11) leads to "Internal Server Error".

Re: Finished-[6.5] Integrated Index Page (IIP) 6.5
234234 #276596 01/17/2005 6:04 PM
Joined: Jul 2001
Posts: 808
Coder
Offline
Coder
Joined: Jul 2001
Posts: 808
Just to remember:

#120884 - 10/05/04 10:39 AM
Minor Bug:

IIP control panel, index file options, at the bottom:

Should we cache the Short Status information to decrease page generation times?
If so, how many minutes should lapse before updating? (0 disables)

if you enter a numeric value in the box and save it the value is disapered next time enter this page.


scroungr
Re: Finished-[6.5] Integrated Index Page (IIP) 6.5 [Re: Zarzal]
#120893 - 10/05/04 02:42 PM

okay will check when I get some time

Sponsored Links
Re: Error on the Entrace page at "Last Seen"
234234 #276597 01/19/2005 5:28 PM
Joined: Oct 2002
Posts: 105
ehm Offline
Journeyman
Offline
Journeyman
Joined: Oct 2002
Posts: 105
Sorry took so long to repond. I had some problems with my server...
Ok. for the 2 queries:

The first query returns nothing. Blank
The second query returns the last then users.

$configpal[moreSeen] = "";
$configpal[lastonDisplayNum] = "10";
$configpal[modifiedlastseen] = "";

Hope it will help.

Re: Error on the Entrace page at "Last Seen"
mrnocal #276598 01/19/2005 8:06 PM
Joined: Oct 2003
Posts: 2,305
Old Hand
OP Offline
Old Hand
Joined: Oct 2003
Posts: 2,305
Hmm on the IIP User Management Tab did you


Use enhanced who's online tracking?
Before using this option you must follow THESE setup instructions or this WILL NOT WORK CORRECTLY!

and click on the the word THESE?

Re: Error on the Entrace page at "Last Seen"
234234 #276599 01/19/2005 9:59 PM
Joined: Oct 2002
Posts: 105
ehm Offline
Journeyman
Offline
Journeyman
Joined: Oct 2002
Posts: 105
No. I'm not using Enhaced who's online tracking.
Should I?
I clicked on the "THESE" link and received a message "You need to run the "Modify My Database" link in initial setup before using this step."

Re: Error on the Entrace page at "Last Seen"
mrnocal #276600 01/20/2005 9:39 AM
Joined: Oct 2003
Posts: 2,305
Old Hand
OP Offline
Old Hand
Joined: Oct 2003
Posts: 2,305
well I would

Re: Error on the Entrace page at "Last Seen"
234234 #276601 01/20/2005 9:47 PM
Joined: Oct 2002
Posts: 105
ehm Offline
Journeyman
Offline
Journeyman
Joined: Oct 2002
Posts: 105
OK. I changed modes and still doing the very same thing...
It's not moving to the next 10 users...
Any other ideas to try?

Thank you

Sponsored Links
Re: Error on the Entrace page at "Last Seen"
mrnocal #276602 01/21/2005 8:39 AM
Joined: Oct 2003
Posts: 2,305
Old Hand
OP Offline
Old Hand
Joined: Oct 2003
Posts: 2,305
rerun the query

SELECT U_Username,U_LastSeen,U_Number,U_Visible
FROM w3t_Users
WHERE U_LastSeen <> U_Registered
AND U_LastSeen IS NOT NULL
AND U_Number > 1
ORDER BY U_LastSeen DESC
LIMIT 10

then wait a bit and run it again and see if that query changes the values that you see. that is the key query

Re: Error on the Entrace page at "Last Seen"
234234 #276603 01/21/2005 12:53 PM
Joined: Oct 2002
Posts: 105
ehm Offline
Journeyman
Offline
Journeyman
Joined: Oct 2002
Posts: 105
I run that query 3 times in 15 minutes.
It always return blank.
And if you have a minute, check my page at Entrance:
http://www.imigrar.com/forum/index.php?Cat=0
the Last 10 now are complete empty (since I changed the mode).
It's in Portugues, but please look for the words "Passaram por aqui", in the central column, just below a "Sponsored by" banner.

Do you want me to change back the mode?

Re: Error on the Entrace page at "Last Seen"
mrnocal #276604 01/21/2005 3:46 PM
Joined: Oct 2003
Posts: 2,305
Old Hand
OP Offline
Old Hand
Joined: Oct 2003
Posts: 2,305
I see

Online 1 member (Threadsdev) and 10 guests have been online with in the last 10 minutes.

ok send me a PM

Re: Error on the Entrace page at "Last Seen"
234234 #276605 01/23/2005 3:44 AM
Joined: Oct 2003
Posts: 2,305
Old Hand
OP Offline
Old Hand
Joined: Oct 2003
Posts: 2,305
okay think I found the isue with Last seen I have updated the main zip but

find in lastseenpal.php

$thisinstant = $html -> get_date();
$lastonlimit;
$lastonstart = $configpal[moreSeen] + 0;
$lastonend = $configpal[lastonDisplayNum];
$moreSeen = $configpal[moreSeen] + $configpal[lastonDisplayNum];
$date = $thisinstant;


change to

$thisinstant = $html -> get_date();
$lastonlimit;
$lastonstart = $moreSeen + 0;
$lastonend = $configpal[lastonDisplayNum];
$moreSeen = $moreSeen + $configpal[lastonDisplayNum];
$date = $thisinstant;

Re: Error on the Entrace page at "Last Seen"
234234 #276606 01/23/2005 8:45 AM
Joined: Jul 2001
Posts: 808
Coder
Offline
Coder
Joined: Jul 2001
Posts: 808
there must be another bug.
The initial setup told me while trying to modify the database:

IIP 6.5 modifications already exists. Nothing more to be done here...

If I try to run .../ubbthreads/pals/lastseensetup.php I get :

You need to run the "Modify My Database" link in initial setup before using this step.

Set Use enhanced who's online tracking? to yes give me a empty pal box.

I use IIP very long time so my database modification is from a old version. What should I do ?

Re: Error on the Entrace page at "Last Seen"
landyphil #276607 01/23/2005 11:58 AM
Joined: Oct 2003
Posts: 2,305
Old Hand
OP Offline
Old Hand
Joined: Oct 2003
Posts: 2,305
yeah looking into why the U_LastSeen field doesn't populate. For now set enhanced to no and should be okay.

Re: Finished-[6.5.1] Integrated Index Page (IIP) 6.5
234234 #276608 01/24/2005 7:01 AM
Joined: Jul 2001
Posts: 808
Coder
Offline
Coder
Joined: Jul 2001
Posts: 808
Problem with exploitfix:

There is an inofficial exploitfix on www.infopop.com for the file ubb.inc.php

Code
// security fix from www.ubbcentral.com/boards/showflat.php/Cat/0/Number/40981/an/0/page/0#40981<br />@explode_data();<br />$Cat = get_input("Cat","get");<br />if (preg_match("/[^\d,]/", $Cat)){<br />$timea = getmicrotime();<br />$html = new html;<br />$html -> not_right("The script has received a malformed URL.");<br />}


If you apply this, the newspal.php have a malfunction. You are no longer able to click links. the $cat seems to bee empty and this result in a broken link with ...//... and a missing cat number.

Re: Finished-[6.5.1] Integrated Index Page (IIP) 6.5
landyphil #276609 01/24/2005 8:37 AM
Joined: Oct 2003
Posts: 2,305
Old Hand
OP Offline
Old Hand
Joined: Oct 2003
Posts: 2,305
have you tried the non spider friendly newspal?

Re: Finished-[6.5.1] Integrated Index Page (IIP) 6.5
234234 #276610 01/24/2005 9:24 AM
Joined: Jul 2001
Posts: 808
Coder
Offline
Coder
Joined: Jul 2001
Posts: 808
no, but thats a good tip I go and will try it.

/edit: ok, this help. I try it. But if Infopop include this exploitfix you should watch it for spiderfrindly. So I use unfriendly and the fix works. Thanks again for the tip.

Last edited by Zarzal; 01/24/2005 9:32 AM.
Re: Finished-[6.5.1] Integrated Index Page (IIP) 6.5
landyphil #276611 01/24/2005 10:13 AM
Joined: Oct 2003
Posts: 2,305
Old Hand
OP Offline
Old Hand
Joined: Oct 2003
Posts: 2,305
np. I will take a look at the spider friendly

Re: Finished-[6.5.1] Integrated Index Page (IIP) 6.5
234234 #276612 01/30/2005 3:08 PM
Joined: Aug 2004
Posts: 173
Member
Offline
Member
Joined: Aug 2004
Posts: 173
I have been testing my "Recommend Us!" at its all working fine.

How would I be able to BCC me on every mail that is sent? I only want this to be noisey

Re: Finished-[6.5.1] Integrated Index Page (IIP) 6.5
DMClark #276613 01/30/2005 5:39 PM
Joined: Oct 2003
Posts: 2,305
Old Hand
OP Offline
Old Hand
Joined: Oct 2003
Posts: 2,305
guess you could write something up for that.

Re: Finished-[6.5.1] Integrated Index Page (IIP) 6.5
234234 #276614 01/30/2005 5:57 PM
Joined: Aug 2004
Posts: 173
Member
Offline
Member
Joined: Aug 2004
Posts: 173
I had a go, but it stopped working altogether

I must be stupid...I can't get this to work...
DMClark #276615 01/31/2005 2:15 AM
Joined: Jan 2003
Posts: 5
Lurker
Offline
Lurker
Joined: Jan 2003
Posts: 5
After banging my head against the wall trying to get just PHP, MySQL, and Threads installed, I finally got it.

I attempted to install IIP, but I ended up with this mess:

http://aow.rpg.st

Now, you can see, my threads install works...

http://aow.rpg.st/ubbthreads/ubbthreads.php

Can anyone guide me here? I feel so stupid at this point. There has to be an easier way...

~Eric C.

Re: I must be stupid...I can't get this to work...
Gepard #276616 01/31/2005 3:26 PM
Joined: Oct 2003
Posts: 2,305
Old Hand
OP Offline
Old Hand
Joined: Oct 2003
Posts: 2,305
check your path settings

Failed opening '/ubbthreads/includes/main.inc.php' for inclusion (include_path='.;c:\php4\pear')

means its looking in c:\php4\pear for the /ubbthreads/includes/main.inc.php

Re: I must be stupid...I can't get this to work...
234234 #276617 01/31/2005 4:58 PM
Joined: Jan 2003
Posts: 5
Lurker
Offline
Lurker
Joined: Jan 2003
Posts: 5
Thanks for the reply.

I checked my include_path in my php.ini, and it's commented out. I tried to change it to:

include_path = ".;c:\php\includes;c:\inetpub\wwwroot\aowroot"

But that just changes the error message to:

'/ubbthreads/includes/main.inc.php' for inclusion (include_path='.;c:\php\includes;c:\inetpub\wwwroot\aowroot')

Now, the root of that website is c:\inetpub\wwwroot\aowroot

Threads is in c:\inetpub\wwwroot\aowroot\ubbthreads

The IIP index.php is in the aowroot folder.

What should my include_path be?

~Eric C.

Re: I must be stupid...I can't get this to work...
Gepard #276618 02/01/2005 2:16 AM
Joined: Oct 2003
Posts: 2,305
Old Hand
OP Offline
Old Hand
Joined: Oct 2003
Posts: 2,305
c:\inetpub\wwwroot\aowroot\ubbthreads\includes\main.inc.php

Re: I must be stupid...I can't get this to work...
234234 #276619 02/01/2005 9:59 AM
Joined: Jan 2003
Posts: 5
Lurker
Offline
Lurker
Joined: Jan 2003
Posts: 5
Thank you again for your reply, scroungr.

Well, I gave that a try, and that didn't work either. Now the error looks like this:

[:"purple"]PHP Notice: Undefined variable: Cat in C:\Inetpub\wwwroot\aowroot\index.php on line 66 PHP Warning: main(/ubbthreads/includes/main.inc.php): failed to open stream: No such file or directory in C:\Inetpub\wwwroot\aowroot\index.php on line 70 PHP Warning: main(): Failed opening '/ubbthreads/includes/main.inc.php' for inclusion (include_path='.;c:\php\includes;c:\inetpub\wwwroot\aowroot;c:\inetpub\wwwroot\aowroot\ubbthreads\includes\main.inc.php') in C:\Inetpub\wwwroot\aowroot\index.php on line 70 PHP Notice: Undefined variable: myprefs in C:\Inetpub\wwwroot\aowroot\index.php on line 71 PHP Warning: main(/ubbthreads/pals/languages//genericpal.php): failed to open stream: No such file or directory in C:\Inetpub\wwwroot\aowroot\index.php on line 71 PHP Warning: main(): Failed opening '/ubbthreads/pals/languages//genericpal.php' for inclusion (include_path='.;c:\php\includes;c:\inetpub\wwwroot\aowroot;c:\inetpub\wwwroot\aowroot\ubbthreads\includes\main.inc.php') in C:\Inetpub\wwwroot\aowroot\index.php on line 71 PHP Fatal error: Cannot instantiate non-existent class: user in C:\Inetpub\wwwroot\aowroot\index.php on line 75[/]

I'm no expert at this by any means, but I see a couple of potential things in this error. I looked at the index.php, and it's referring to the variable $thispath from the main.inc.php

Here are the contents of my main.inc.php:

[:"purple"]<?

// THIS NEEDS TO BE SET, OTHERWISE ADMIN SCRIPTS WILL NOT WORK
// THIS IS THE ACTUAL PATH TO YOUR PHP INSTALLATION
$thispath = "c:\inetpub\wwwroot\aowroot\ubbthreads";

// PATH TO YOUR config.inc.php file. BY DEFAULT THIS IS THE
// SAME AS , BUT IF YOU MOVE config.inc.php TO ANY
// OTHER LOCATION YOU MUST SPECIFY IT HERE.
$configdir = "c:\inetpub\wwwroot\aowroot\ubbthreads\includes";

// DO NOT EDIT ANYTHING BELOW THIS LINE!
include("$thispath/ubbt.inc.php");

// Page load times
$timea = getmicrotime();

?> [/]

The other thing that I'm wondering about is this: If something is wrong with the include_path, why does threads work? After all, it's only the IIP that I can't use...

Thanks again for your help.

~Eric

Re: I must be stupid...I can't get this to work...
Gepard #276620 02/01/2005 10:42 AM
Joined: Jul 2001
Posts: 808
Coder
Offline
Coder
Joined: Jul 2001
Posts: 808
I dont have a windows server for testing but I rember that I read someting about / and \ in the config files. You use c:\... whats about using unix like /wwwroot/aowroot/... and not filesystem like windows paths.

Re: I must be stupid...I can't get this to work...
landyphil #276621 02/01/2005 12:48 PM
Joined: Oct 2003
Posts: 2,305
Old Hand
OP Offline
Old Hand
Joined: Oct 2003
Posts: 2,305
in the index php you need to set

// WHAT IS THE FULL PATH TO YOUR UBB.threads INSTALLATION (do not include the trailing slash)
$palspath = "";

to

// WHAT IS THE FULL PATH TO YOUR UBB.threads INSTALLATION (do not include the trailing slash)
$palspath = "c:/inetpub/wwwroot/aowroot/ubbthreads";


now create some forums... and good luck

Re: I must be stupid...I can't get this to work...
234234 #276622 02/01/2005 7:55 PM
Joined: Jan 2003
Posts: 5
Lurker
Offline
Lurker
Joined: Jan 2003
Posts: 5
Thank you. Thank you. Thank you!

~Eric

Re: Finished-[6.5.1] Integrated Index Page (IIP) 6.5
234234 #276623 02/16/2005 5:46 AM
Joined: Jun 2002
Posts: 160
Member
Offline
Member
Joined: Jun 2002
Posts: 160
Is this confirmed to work under UBB.Threads 6.5.1 final yet?

Re: Finished-[6.5.1] Integrated Index Page (IIP) 6.5
astre #276624 02/16/2005 11:07 AM
Joined: Mar 2000
Posts: 21,079
Likes: 3
I type Like navaho
Offline
I type Like navaho
Joined: Mar 2000
Posts: 21,079
Likes: 3
works for me at www.cccbmt.org


- Allen wavey
- What Drives You?
Re: Finished-[6.5.1] Integrated Index Page (IIP) 6.5
SurfMinister #276625 02/16/2005 11:08 AM
Joined: Mar 2000
Posts: 21,079
Likes: 3
I type Like navaho
Offline
I type Like navaho
Joined: Mar 2000
Posts: 21,079
Likes: 3
oops, I'm still running iip 5.5


- Allen wavey
- What Drives You?
Re: Finished-[6.5.1] Integrated Index Page (IIP) 6.5
SurfMinister #276626 02/16/2005 11:14 AM
Joined: Oct 2003
Posts: 2,305
Old Hand
OP Offline
Old Hand
Joined: Oct 2003
Posts: 2,305
nope and since I haven't upgraded to 6.5.1 I will need input from others...

Re: Finished-[6.5.1] Integrated Index Page (IIP) 6.5
234234 #276627 02/17/2005 6:52 AM
Joined: Jul 2001
Posts: 808
Coder
Offline
Coder
Joined: Jul 2001
Posts: 808
I run it on www.dragon-clan.de without bigger problem. I use everywhere non-spider url's. There are some litte problems allready described here in this thread but nothing real big.

I have 2 major problems, but this is not based on UBBt 6.5.1 (I noticed this before).

1) The cache timer doesnt work well. I set it to cache news for 10 minutes but it took time between 30 and 60 minutes, so I disable caching.

2) Setup 4 different newspals with 5 news each. Enable HTML, Names, Avatars and Date will sometimes crash the page generation by mysql (timed out or something else) I get an 503 error from my server. I change the newssetup as follows: Box 1 with name, avatar, date and HTML. All other boxes set to no pictures, no name, date and HTML. If I try to strip html too I get 503 again. Seems to much queries or so.

General I say, you can use it with 6.5.1

Remeber to fix the little bugs in the control panel

Re: Finished-[6.5.1] Integrated Index Page (IIP) 6.5
landyphil #276628 02/17/2005 3:33 PM
Joined: Oct 2001
Posts: 18
Newbie
Offline
Newbie
Joined: Oct 2001
Posts: 18
Ok just updated a 6.5 instalation to 6.5.1.
I'm using the IIP 6.5.1 from this thread

now threads that show up in "current threads" report
"We cannot proceed.
There was a problem looking up the post in our database.
Please use your back button to return to the previous page."
when they are selected.

also in "top posters" when I click on any name (including the one I'm logged in with) I get "We cannot proceed.
This user is no longer in our database.

Please use your back button to return to the previous page."

Re: Finished-[6.5.1] Integrated Index Page (IIP) 6.5
LiuKang #276629 02/17/2005 3:48 PM
Joined: Oct 2001
Posts: 18
Newbie
Offline
Newbie
Joined: Oct 2001
Posts: 18
also now when a user chooses to select the Entrance as a starting point it throws up reporting:

[] We cannot proceed.

Script: /var/www/html/ubbthreads/pals/pollpal.php
Line#: 85
SQL Error: You have an error in your SQL syntax near ') AND B_Poll != '' AND (B_Sticky = 0 OR B_Sticky IS NULL) ORDER ' at line 6
SQL Error #: 1064
Query: SELECT B_Poll,B_Replies,B_Number,B_Board,B_Posted, B_Subject FROM w3t_Posts WHERE B_Number = B_Main AND B_Approved = 'yes' AND () AND B_Poll != '' AND (B_Sticky = 0 OR B_Sticky IS NULL) ORDER BY B_Posted DESC LIMIT 0,1



[/]

Re: Finished-[6.5.1] Integrated Index Page (IIP) 6.5
LiuKang #276630 02/17/2005 4:18 PM
Joined: Jul 2001
Posts: 808
Coder
Offline
Coder
Joined: Jul 2001
Posts: 808
Owen93, be sure to take the files from the spiderUNfriendly directrory. If you take a closer look to your URL's you see that something behind cat is missing and you have two following // in it.

Using the files from this directory should solve it.

Re: Finished-[6.5.1] Integrated Index Page (IIP) 6.5
landyphil #276631 02/17/2005 6:17 PM
Joined: Oct 2001
Posts: 18
Newbie
Offline
Newbie
Joined: Oct 2001
Posts: 18
ETA -

Ok I found the "Unspiderfriendly" dir
I'll poke around and see if I can deduce where these file might go ?

Last edited by owen93; 02/17/2005 6:20 PM.
Page 8 of 11 1 2 6 7 8 9 10 11

Link Copied to Clipboard
Donate Today!
Donate via PayPal

Donate to UBBDev today to help aid in Operational, Server and Script Maintenance, and Development costs.

Please also see our parent organization VNC Web Services if you're in the need of a new UBB.threads Install or Upgrade, Site/Server Migrations, or Security and Coding Services.
Recommended Hosts
We have personally worked with and recommend the following Web Hosts:
Stable Host
bluehost
InterServer
Visit us on Facebook
Member Spotlight
AllenAyres
AllenAyres
Texas
Posts: 21,079
Joined: March 2000
Forum Statistics
Forums63
Topics37,544
Posts293,777
Members13,838
Most Online5,166
Sep 15th, 2019
Today's Statistics
Currently Online 195
Topics Created 0
Posts Made 0
Users Online 3
Birthdays 12
Top Posters
AllenAyres 21,079
JoshPet 10,369
LK 7,394
Lord Dexter 6,708
Gizmo 5,806
Greg Hard 4,625
Top Posters(30 Days)
isaac 2
Gizmo 1
Top Likes Received
isaac 40
Gizmo 10
Brett 7
Morgan 2
Top Likes Received (30 Days)
isaac 1
The UBB.Developers Network (UBB.Dev/Threads.Dev) is ©2000-2020 VNC Web Services

 
Powered by UBB.threads™ PHP Forum Software 7.7.5
(Snapshot build 20200802.dev)
Responsive Width:

PHP: 5.4.45 Page Time: 0.093s Queries: 96 (0.038s) Memory: 3.6658 MB (Peak: 4.1137 MB) Data Comp: Zlib Server Time: 2020-08-12 18:52:21 UTC
Valid HTML 5 and Valid CSS