Previous Thread
Next Thread
Print Thread
Rate Thread
Page 3 of 6 1 2 3 4 5 6
Re: [6.7] [beta] UBB.Uploader #203031 07/28/2004 4:34 PM
Joined: Jan 2003
Posts: 3,456
Likes: 2
Ian Spence Offline
Master Hacker
Offline
Master Hacker
Joined: Jan 2003
Posts: 3,456
Likes: 2
line 1251

Sponsored Links
Re: [6.7] [beta] UBB.Uploader #203032 07/28/2004 4:45 PM
Joined: Jul 2004
Posts: 18
Webberver1 Offline
Junior Member
Offline
Junior Member
Joined: Jul 2004
Posts: 18
I must not have the right file because my line 1251 gives me:
sub MakeComponentHTML_modqresline {

And I cannot find any variation of the code I need to change.

I am using this version of UBB: UBB.classic™ 6.7.1

Re: [6.7] [beta] UBB.Uploader #203033 07/28/2004 4:52 PM
Joined: Jan 2003
Posts: 3,456
Likes: 2
Ian Spence Offline
Master Hacker
Offline
Master Hacker
Joined: Jan 2003
Posts: 3,456
Likes: 2
you are in cp2_membermanage.pl, not cp2_membermanage.cgi

big difference

Re: [6.7] [beta] UBB.Uploader #203034 07/28/2004 6:12 PM
Joined: Jul 2004
Posts: 18
Webberver1 Offline
Junior Member
Offline
Junior Member
Joined: Jul 2004
Posts: 18
DOH!!! I was having a blond moment...
Ok I got it installed but when I click on the link to upload file, a popup window comes back with this message:

Unable to detect referer. You must click the upload link directly to upload files.

Where did I screw up?

Re: [6.7] [beta] UBB.Uploader #203035 07/28/2004 6:16 PM
Joined: Jan 2003
Posts: 3,456
Likes: 2
Ian Spence Offline
Master Hacker
Offline
Master Hacker
Joined: Jan 2003
Posts: 3,456
Likes: 2
http://pavioni.com/scripts/dl.php/Uploader6.7_2.zip

upload the ubb_upload.cgi script from that zip

Sponsored Links
Re: [6.7] [beta] UBB.Uploader #203036 07/28/2004 6:34 PM
Joined: Jul 2004
Posts: 18
Webberver1 Offline
Junior Member
Offline
Junior Member
Joined: Jul 2004
Posts: 18
Ok I'm not that Blond LOL LOL
I did.... and what I posted above is what I get.

Re: [6.7] [beta] UBB.Uploader #203037 07/28/2004 6:36 PM
Joined: Jul 2004
Posts: 18
Webberver1 Offline
Junior Member
Offline
Junior Member
Joined: Jul 2004
Posts: 18
I did notice that one of the files to be edited was the Ultimatebb.cgi file but on the instructions no modifications were provided.

Could that be it?

Re: [6.7] [beta] UBB.Uploader #203038 07/28/2004 6:41 PM
Joined: Jul 2004
Posts: 18
Webberver1 Offline
Junior Member
Offline
Junior Member
Joined: Jul 2004
Posts: 18
I hope you took my post as fun and not a witchy post...I was just being humorous.

I really can't thank you enough for helping me with this.

Re: [6.7] [beta] UBB.Uploader #203039 07/28/2004 6:47 PM
Joined: Jul 2004
Posts: 18
Webberver1 Offline
Junior Member
Offline
Junior Member
Joined: Jul 2004
Posts: 18
This is the error I am recieving now:
No such file or directory at D:WebSitesCityofLincolnParkMIcgi-binubb_upload.cgi line 220.
For help, please send mail to this site's webmaster, giving this error message and the time and date of the error. [Wed Jul 28 19:45:33 2004] D:WebSitesCityofLincolnParkMIcgi-binubb_upload.cgi: No such file or directory at D:WebSitesCityofLincolnParkMIcgi-binubb_upload.cgi line 220.

Re: [6.7] [beta] UBB.Uploader #203040 07/28/2004 7:28 PM
Joined: Jan 2003
Posts: 3,456
Likes: 2
Ian Spence Offline
Master Hacker
Offline
Master Hacker
Joined: Jan 2003
Posts: 3,456
Likes: 2
upload the ubb_upload.cgi file from the zip I linked you to

Sponsored Links
Re: [6.7] [beta] UBB.Uploader #203041 07/28/2004 7:35 PM
Joined: Jul 2004
Posts: 18
Webberver1 Offline
Junior Member
Offline
Junior Member
Joined: Jul 2004
Posts: 18
I uploaded the ubb_upload.cgi from the file in your previous post and that is the error I am receiving.
No such file or directory at D:WebSitesCityofLincolnParkMIcgi-binubb_upload.cgi line 220.
For help, please send mail to this site's webmaster, giving this error message and the time and date of the error. [Wed Jul 28 19:45:33 2004] D:WebSitesCityofLincolnParkMIcgi-binubb_upload.cgi: No such file or directory at D:WebSitesCityofLincolnParkMIcgi-binubb_upload.cgi line 220.

I thought maybe I needed to clear the cashe so I did that but get the same error.

I'm getting serious grey hairs now. LOL

Re: [6.7] [beta] UBB.Uploader #203042 07/28/2004 7:39 PM
Joined: Jan 2003
Posts: 3,456
Likes: 2
Ian Spence Offline
Master Hacker
Offline
Master Hacker
Joined: Jan 2003
Posts: 3,456
Likes: 2
go into your CP, primary settings, and set the upload settings

Re: [6.7] [beta] UBB.Uploader #203043 07/28/2004 8:03 PM
Joined: Jul 2004
Posts: 18
Webberver1 Offline
Junior Member
Offline
Junior Member
Joined: Jul 2004
Posts: 18
I'm in there but I put the D: path to my cgi bin...should this be the url to my cgi bin?

Re: [6.7] [beta] UBB.Uploader #203044 07/28/2004 8:04 PM
Joined: Jul 2004
Posts: 18
Webberver1 Offline
Junior Member
Offline
Junior Member
Joined: Jul 2004
Posts: 18
Oops...it's that darn blond in me again...Scratch that post...

I am so glad you are patient....I woulda yelled at me by now.

Re: [6.7] [beta] UBB.Uploader #203045 07/28/2004 8:09 PM
Joined: Jul 2004
Posts: 18
Webberver1 Offline
Junior Member
Offline
Junior Member
Joined: Jul 2004
Posts: 18
One other thing...the allowable extensions says to add them with a space
So I did this:
zip pdf txt for the regular files

and this for the avatars:
gif jpeg jpg fla

When I click submit in CP, I receive this error:
Form validation errors:

: You did not enter a value for this field
: You did not enter a value for this field

Re: [6.7] [beta] UBB.Uploader #203046 07/28/2004 8:13 PM
Joined: Jul 2004
Posts: 18
Webberver1 Offline
Junior Member
Offline
Junior Member
Joined: Jul 2004
Posts: 18
I just tried to use the exact examples in the explanation field and I receive the same error:

This is what I used: zip txt tar.gz tar

Re: [6.7] [beta] UBB.Uploader #203047 07/28/2004 10:56 PM
Joined: Jan 2003
Posts: 3,456
Likes: 2
Ian Spence Offline
Master Hacker
Offline
Master Hacker
Joined: Jan 2003
Posts: 3,456
Likes: 2
https://www.ubbdev.com/ubb/ultimatebb.php/topic/33/168/5.html#000068

do the steps in that post, and make sure you filled in info for every upload field, including amount of byte uploads can be, etc

Re: [6.7] [beta] UBB.Uploader #203048 07/28/2004 11:41 PM
Joined: Jul 2004
Posts: 18
Webberver1 Offline
Junior Member
Offline
Junior Member
Joined: Jul 2004
Posts: 18
Hi Ian,

I made the changes as per the post link you gave and updated my CP info and it took the update after I submitted.....I uploaded the file you posted above.

I am still receiving this error when I attempt to upload a file from the link:

No such file or directory at D:WebSitesCityofLincolnParkMIcgi-binubb_upload.cgi line 220.
For help, please send mail to this site's webmaster, giving this error message and the time and date of the error. [Thu Jul 29 00:38:41 2004] D:WebSitesCityofLincolnParkMIcgi-binubb_upload.cgi: No such file or directory at D:WebSitesCityofLincolnParkMIcgi-binubb_upload.cgi line 220.

I went through and doublechecked to make sure that I completed all the code changes.

I'm at a lost.....my head is getting more gray hair now LOL LOL

Re: [6.7] [beta] UBB.Uploader #203049 07/29/2004 12:09 AM
Joined: Jan 2003
Posts: 3,456
Likes: 2
Ian Spence Offline
Master Hacker
Offline
Master Hacker
Joined: Jan 2003
Posts: 3,456
Likes: 2
It's saying that was you entered for the path to upload is invalid

Re: [6.7] [beta] UBB.Uploader #203050 07/29/2004 2:25 PM
Joined: Jul 2004
Posts: 18
Webberver1 Offline
Junior Member
Offline
Junior Member
Joined: Jul 2004
Posts: 18
Ok That all works now except when the graphic is uploaded, (the url is correct) I always get a broken graphic indicator.

I read other posts in this topic -- one poster had a garbled graphic issue but I get a broken graphic.

I'm not sure how to fix this issue.

Re: [6.7] [beta] UBB.Uploader #203051 07/29/2004 2:43 PM
Joined: Jan 2003
Posts: 3,456
Likes: 2
Ian Spence Offline
Master Hacker
Offline
Master Hacker
Joined: Jan 2003
Posts: 3,456
Likes: 2
the url to the folder you entered does correspond to the path you entered, right?

Re: [6.7] [beta] UBB.Uploader #203052 07/29/2004 7:56 PM
Joined: Jan 2000
Posts: 5,788
Gizmo Offline
UBB.Dev / UBB.Wiki Owner
Time Lord
Offline
UBB.Dev / UBB.Wiki Owner
Time Lord
Joined: Jan 2000
Posts: 5,788
Have you tried accessing the url where the graphic is via your browser to ensure it is in fact where the UBB is being told where it is?


UBB.Dev - Putting Dev into UBB.threads
Company: VNC Web Services - UBB.threads Scripts and Scripting, Install and Upgrade Services, Site and Server Maintenance.
Forums: A Gardeners Forum, Scouters World, and UGN Security
UBB.Threads: My UBB Themes, UBB.Sitemaps
Re: [6.7] [beta] UBB.Uploader #203053 08/01/2004 12:16 PM
Joined: Jan 2004
Posts: 15
Cho Phoo Offline
Junior Member
Offline
Junior Member
Joined: Jan 2004
Posts: 15
In the install.txt . They wrote :

Quote
quote:
########################################################
###Open ubb_lib.cgi
########################################################

########
# find #
########

$vars_config{'MaxMemFields'} = 43;
But I cound found this line in my ubb_lib.cgi ( I'm using UBB 6.6)

And After add some line to vars_wordlets.cgi

example:
q!upload-_-form-title! => q!%%BBTITLE%% Upload Form!,
q!upload-_-form-submit! => q! Upload !,
q!upload-_-form-link! => q!Upload File!,
q!upload-_-form-manager! => q!Upload Manager!,
q!upload-_-manager-title! => q!%%BBTITLE%% Upload Manager!,
q!upload-_-manager-delete! => q!Delete!,

In Control Panel -->Wordlets List-->Primary, I can't see them.

Who know how to fix that error, help me !!!

Re: [6.7] [beta] UBB.Uploader #203054 08/01/2004 12:45 PM
Joined: Jan 2003
Posts: 3,456
Likes: 2
Ian Spence Offline
Master Hacker
Offline
Master Hacker
Joined: Jan 2003
Posts: 3,456
Likes: 2
This is a 6.7 mod

Re: [6.7] [beta] UBB.Uploader #203055 08/19/2004 1:24 AM
Joined: Aug 2004
Posts: 14
Alan Thompson Offline
Junior Member
Offline
Junior Member
Joined: Aug 2004
Posts: 14
OK. I've reread this topic a few times and managed to solve most of the problems mentioned here except for the corrupted image issue a few others are having.

The files are getting uploaded to the right place, I can check them in FTP. But when I try to browse them, they're corrupted. Some display partially, some don't display at all and just return the little red X in IE. Mozilla is a little more helpful, returning an error message:

Quote
quote:
The image “http://www.sharpeiforums.com/ubb/uploads/00000001/amber-II.jpg” cannot be displayed, because it contains errors.
This site is on shared hosting in a Windows 2K server. I'm running WinXP Pro. Any ideas, anyone?

Re: [6.7] [beta] UBB.Uploader #203056 08/19/2004 4:04 AM
Joined: May 2001
Posts: 1,042
Likes: 7
Brett Offline OP
Moderator
OP Offline
Moderator
Joined: May 2001
Posts: 1,042
Likes: 7
This was the same issue that another got earlier this month.

Just too make sure you downloaded from http://pavioni.com/scripts/dl.php/Uploader6.7.zip ? If not, dl that and reupload ubb_upload.cgi.

Re: [6.7] [beta] UBB.Uploader #203057 08/19/2004 9:22 AM
Joined: Aug 2004
Posts: 14
Alan Thompson Offline
Junior Member
Offline
Junior Member
Joined: Aug 2004
Posts: 14
Hi Brett,

Thanks for getting back so quickly. I know you're busy.

Per Ian Spence's post earlier in this thread, the file I had last DL'ed was from Uploader6.7_2. I downloaded the one you posted above and installed it "as is," without making any of the hacks mentioned elsewhere in this thread. Now I get this error:

Quote
quote:
Can't locate /vars_misc.cgi in @INC (@INC contains: ./Modules . d:htmluserssharpeiforumscomhtmlcgi-bin d:htmluserssharpeiforumscomhtmlcgi-binModules D:/Perl/lib D:/Perl/site/lib) at d:htmluserssharpeiforumscomhtmlcgi-binubb_upload.cgi line 72.

For help, please send mail to this site's webmaster, giving this error message and the time and date of the error.

[Thu Aug 19 09:11:26 2004] ubb_upload.cgi: Can't locate /vars_misc.cgi in @INC (@INC contains: ./Modules . d:htmluserssharpeiforumscomhtmlcgi-bin d:htmluserssharpeiforumscomhtmlcgi-binModules D:/Perl/lib D:/Perl/site/lib) at d:htmluserssharpeiforumscomhtmlcgi-binubb_upload.cgi line 72.
Do I need to hack this file per earlier posts?

Re: [6.7] [beta] UBB.Uploader #203058 08/20/2004 10:11 AM
Joined: Aug 2004
Posts: 14
Alan Thompson Offline
Junior Member
Offline
Junior Member
Joined: Aug 2004
Posts: 14
Well, I rolled back to the ubb_upload.cgi version in Ian's link to 6_7_2 and that solved the problem above but now I'm back to dealing with the corruption problem.

Re: [6.7] [beta] UBB.Uploader #203059 08/20/2004 10:24 AM
Joined: Aug 2004
Posts: 14
Alan Thompson Offline
Junior Member
Offline
Junior Member
Joined: Aug 2004
Posts: 14
More info on the file corruption problem here in UBBDEV in another topic:
https://www.ubbdev.com/ubb/ultimatebb.php/topic/20/252/8.html

Re: [6.7] [beta] UBB.Uploader #203060 08/20/2004 3:22 PM
Joined: Aug 2004
Posts: 14
Alan Thompson Offline
Junior Member
Offline
Junior Member
Joined: Aug 2004
Posts: 14
"Sigh" I think I'm just two code lines away from fixing this problem:

If only I knew PERL...

I don't like Window$ any more than the rest of you but I'm stuck with it for now... :rolleyes:

Re: [6.7] [beta] UBB.Uploader #203061 08/20/2004 3:26 PM
Joined: Jan 2003
Posts: 3,456
Likes: 2
Ian Spence Offline
Master Hacker
Offline
Master Hacker
Joined: Jan 2003
Posts: 3,456
Likes: 2
This is untested, but try the following.

Find:
Code
	my $fullpath = "$vars_misc{upload_dir}/".$user_number."/$Filename";
my $handle = $filehandle->open('file', 'writeonly', $fullpath);
Add after:
Code
	binmode($in{FILE});

Re: [6.7] [beta] UBB.Uploader #203062 08/20/2004 3:48 PM
Joined: Aug 2004
Posts: 14
Alan Thompson Offline
Junior Member
Offline
Junior Member
Joined: Aug 2004
Posts: 14
Hi Ian,

Thanks, I thought I was getting close. I had put that same line in earlier, only here two lines down:

my $FileSize = 0;
binmode($in{FILE});

Doesn't seem to make any change in either place, tho.

I saw a reference in Dave_L\'s Post to binmode being inserted on two lines and I assumed (PERL-dope that I am) a pair was required for file read and write, similar to his example of
Code
binmode $File_Handle;
binmode OUTFILE;
while ($Bytes = read($File_Handle,$Buffer,1024))
{ $BytesRead += $Bytes;
print OUTFILE $Buffer;}
Or does $handle take care of both?

Re: [6.7] [beta] UBB.Uploader #203063 08/21/2004 11:39 PM
Joined: Aug 2004
Posts: 14
Alan Thompson Offline
Junior Member
Offline
Junior Member
Joined: Aug 2004
Posts: 14
I'll try a fresh install working from Brett's latest version and see how far I get....

Brett, thanks for all your hard work on this mod. A lot of thought went into it. The interface looked really sweet within my board and I really liked the tight integration. It's exactly what I was looking for.

I just hope I can get it working on this damn Win server. smash

Re: [6.7] [beta] UBB.Uploader #203064 08/22/2004 10:41 PM
Joined: Aug 2004
Posts: 14
Alan Thompson Offline
Junior Member
Offline
Junior Member
Joined: Aug 2004
Posts: 14
OK. I got it to work.

I was still getting the fail posted above after going over all the instructs and reinstall.

Sure enuf, a prob on line 68 breaks the whole script:

require "../variables/vars_config.cgi";};

I don't have "/variables/" - only /cgi-bin/ and /cgi-bin/Modules/. Deleted ../variables/ and fixed it.

Sheesh, Brett, I see now you added binmode and that fixed the corruption prob. Re-ignore my other posts... D'oh!

thumbsup Great script, Brett thumbsup

Re: [6.7] [beta] UBB.Uploader #203065 09/10/2004 12:26 AM
Joined: Nov 2003
Posts: 156
PhillipBurum Offline
Member
Offline
Member
Joined: Nov 2003
Posts: 156
My turn?

Ok, as many of you have probably noticed, I get a lot of the following type errors..

Error message:
Premature end of script headers: ubb_upload.cgi

This time, I was smart enough to upload that file several times both using WSFTP, and the HTTP Interface of my host (PLESK).

I still get that error.

Also, I am unsure as to the settings for the Path and URL in the CP settings. What should these look like to make it use teh default for the Members folders? When I performed the install, the fields both contained "15" for their values. I changed them to the paths, but have been untested due to my server header error.

Also, when I set the CP settings, I always get atleast 5 form validation errors. Although not every check box is selected, there is atleast some text in every text field.

TIA for any help. It is so greatly appreciated!

--Phillip

Re: [6.7] [beta] UBB.Uploader #203066 09/10/2004 12:28 AM
Joined: Nov 2003
Posts: 156
PhillipBurum Offline
Member
Offline
Member
Joined: Nov 2003
Posts: 156
Also, I forgot to mention that not only did I re-upload the file several times, I tried the file from both sources in this thread.

Thanks!

--Phillip

Re: [6.7] [beta] UBB.Uploader #203067 09/10/2004 7:16 AM
Joined: Jan 2003
Posts: 3,456
Likes: 2
Ian Spence Offline
Master Hacker
Offline
Master Hacker
Joined: Jan 2003
Posts: 3,456
Likes: 2
Fixed your site. Problem was #!c:/Perl/bin/Perl.exe at the beginning of the download file, not #!/usr/bin/perl

Re: [6.7] [beta] UBB.Uploader #203068 09/10/2004 11:01 AM
Joined: Nov 2003
Posts: 156
PhillipBurum Offline
Member
Offline
Member
Joined: Nov 2003
Posts: 156
I wondered about that when I opened the file to make sure it wasn't corrupt.

I thought however, that any line that started with a pound sign (#) was remarked out. Appearently not.

Again I learned something new. Thank you!

Re: [6.7] [beta] UBB.Uploader #203069 09/10/2004 11:12 AM
Joined: Nov 2003
Posts: 156
PhillipBurum Offline
Member
Offline
Member
Joined: Nov 2003
Posts: 156
Ok, so i just tried to test it. It seemed to work well. It "Uploaded" the file to MY directory like it should but when I clicked on the URL it supplied, I get a...

Premature end of script headers


On the picture!

I'm so confused. A picture can't do that, can it?

Re: [6.7] [beta] UBB.Uploader #203070 09/10/2004 12:00 PM
Joined: Jan 2003
Posts: 3,456
Likes: 2
Ian Spence Offline
Master Hacker
Offline
Master Hacker
Joined: Jan 2003
Posts: 3,456
Likes: 2
you're uploading into the cgi-bin, so the server assumes anything there is a script. Change the upload directory and it should be fine

Page 3 of 6 1 2 3 4 5 6

Donate Today!
Donate via PayPal

Donate to UBBDev today to help aid in Operational, Server and Script Maintenance, and Development costs.

Please also see our parent organization VNC Web Services if you're in the need of a new UBB.threads Install or Upgrade, Site/Server Migrations, or Security and Coding Services.
Recommended Hosts
We have personally worked with and recommend the following Web Hosts:
Stable Host
bluehost
InterServer
Visit us on Facebook
Member Spotlight
Pilgrim
Pilgrim
NH, USA
Posts: 190
Joined: June 2000
Forum Statistics
Forums63
Topics37,523
Posts293,713
Members13,832
Most Online5,166
Sep 15th, 2019
Top Posters(All Time)
AllenAyres 21,079
JoshPet 10,369
LK 7,394
Lord Dexter 6,708
Gizmo 5,788
Greg Hard 4,625
Top Posters(30 Days)
isaac 12
Gizmo 1
Today's Statistics
Currently Online 92
Topics Created 0
Posts Made 0
Users Online 0
Birthdays 10
Top Likes Received (All Time)
isaac 27
Brett 7
Morgan 2
Slaz 1
DCPhil 1
The UBB.Developers Network (UBB.Dev/Threads.Dev) is ©2000-2019 VNC Web Services

 
Powered by UBB.threads™ PHP Forum Software 7.7.4
(Snapshot build 20191201.dev)
Responsive Width:

PHP: 5.4.45 Page Time: 0.084s Queries: 95 (0.028s) Memory: 3.6253 MB (Peak: 4.0389 MB) Data Comp: Zlib Server Time: 2019-12-11 05:34:11 UTC
Valid HTML 5 and Valid CSS